Bug 963133 - name is misprinted when package is not found
Summary: name is misprinted when package is not found
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ales Kozumplik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-15 08:29 UTC by Rahul Sundaram
Modified: 2014-09-30 23:41 UTC (History)
2 users (show)

Fixed In Version: hawkey-0.3.13-2.git15db39f.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 04:38:28 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rahul Sundaram 2013-05-15 08:29:00 UTC
Description of problem:

dnf should say rpm-test is not found instead of rpm=test


sudo dnf install rpm-test
Setting up Install Process
Resolving Dependencies
--> Starting dependency resolution
--> Finished dependency resolution
Error: nothing provides requested rpm = test
[rahul@mether ~]$sudo yum install rpm-test
Loaded plugins: langpacks, presto, refresh-packagekit
No package rpm-test available.
Error: Nothing to do

Comment 1 Ales Kozumplik 2013-05-15 13:02:06 UTC
related comments in bug 909743.

Comment 2 Ales Kozumplik 2013-05-17 08:18:34 UTC
Fixed by dnf commit d4741f6, will be included in dnf-0.3.6, also needs hawkey-0.3.13 to work properly.

Thanks for the report.

Comment 3 Ales Kozumplik 2013-05-17 08:32:04 UTC
What the output looks like now:

$ dnf install rpm-test
Setting up Install Process
No package rpm-test available.
Error: Nothing to do

Comment 4 Fedora Update System 2013-05-27 13:21:57 UTC
hawkey-0.3.13-2.git15db39f.fc19, dnf-0.3.6-1.git24ce938.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dnf-0.3.6-1.git24ce938.fc19,hawkey-0.3.13-2.git15db39f.fc19

Comment 5 Fedora Update System 2013-05-27 17:03:59 UTC
Package hawkey-0.3.13-2.git15db39f.fc19, dnf-0.3.6-1.git24ce938.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.3.13-2.git15db39f.fc19 dnf-0.3.6-1.git24ce938.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9385/dnf-0.3.6-1.git24ce938.fc19,hawkey-0.3.13-2.git15db39f.fc19
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2013-05-29 17:49:15 UTC
Package hawkey-0.3.13-2.git15db39f.fc19, dnf-0.3.7-1.gitf8bdc98.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.3.13-2.git15db39f.fc19 dnf-0.3.7-1.gitf8bdc98.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9385/hawkey-0.3.13-2.git15db39f.fc19,dnf-0.3.7-1.gitf8bdc98.fc19
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2013-06-07 04:38:28 UTC
hawkey-0.3.13-2.git15db39f.fc19, dnf-0.3.7-1.gitf8bdc98.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.