Bug 963144 - SELinux is preventing /opt/google/chrome/chrome from 'create' accesses on the file libpeerconnection.log.
SELinux is preventing /opt/google/chrome/chrome from 'create' accesses on the...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:fb1d799747ec487b476427d74cb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 04:57 EDT by Igor Vucenovic
Modified: 2013-06-28 17:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-15 11:26:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Vucenovic 2013-05-15 04:57:22 EDT
Description of problem:
This problem was ocure when I start google-chrome ver. 28.0.1500.11 dev
SELinux is preventing /opt/google/chrome/chrome from 'create' accesses on the file libpeerconnection.log.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that chrome should be allowed create access on the libpeerconnection.log file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep chrome /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                libpeerconnection.log [ file ]
Source                        chrome
Source Path                   /opt/google/chrome/chrome
Port                          <Neznámé>
Host                          (removed)
Source RPM Packages           google-chrome-unstable-28.0.1500.11-199640.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.10.0-169.fc17.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.8.11-100.fc17.x86_64 #1 SMP Wed
                              May 1 19:31:26 UTC 2013 x86_64 x86_64
Alert Count                   3
First Seen                    2013-05-14 08:35:20 CEST
Last Seen                     2013-05-15 10:48:56 CEST
Local ID                      5bca4739-94a4-466c-882f-6aa0233c6126

Raw Audit Messages
type=AVC msg=audit(1368607736.304:110): avc:  denied  { create } for  pid=2629 comm="chrome" name="libpeerconnection.log" scontext=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file


type=SYSCALL msg=audit(1368607736.304:110): arch=x86_64 syscall=open success=no exit=EACCES a0=7f9945b2f9a8 a1=441 a2=1b6 a3=0 items=0 ppid=0 pid=2629 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=2 tty=(none) comm=chrome exe=/opt/google/chrome/chrome subj=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 key=(null)

Hash: chrome,chrome_sandbox_t,user_home_dir_t,file,create

audit2allow

#============= chrome_sandbox_t ==============
allow chrome_sandbox_t user_home_dir_t:file create;

audit2allow -R

#============= chrome_sandbox_t ==============
allow chrome_sandbox_t user_home_dir_t:file create;


Additional info:
hashmarkername: setroubleshoot
kernel:         3.8.11-100.fc17.x86_64
type:           libreport

Potential duplicate: bug 960792
Comment 1 Daniel Walsh 2013-05-15 11:26:17 EDT
This is a chrome bug, could you check if a new version of chrome is available.

I believe the next release of chrome fixes this problem.
Comment 2 Raman Gupta 2013-05-30 20:06:03 EDT
I am using the latest Chrome Beta updated today: 

# rpm -q --info google-chrome-beta | head -5
Name        : google-chrome-beta
Version     : 28.0.1500.29
Release     : 202781
Architecture: x86_64
Install Date: Thu 30 May 2013 04:08:47 PM EDT

and I still have this issue.
Comment 3 Daniel Walsh 2013-06-03 14:38:50 EDT
Well they claim they are no longer creating libpeerconnection.log"
Comment 4 Raman Gupta 2013-06-03 15:47:03 EDT
Looks like they are still working on it / its possible it may be fixed in a recent dev build... 

https://code.google.com/p/chromium/issues/detail?id=239048

Note You need to log in before you can comment on or make changes to this bug.