Bug 963150 - Grub does not display "Schrödinger's Cat" menu entry correctly
Grub does not display "Schrödinger's Cat" menu entry correctly
Status: CLOSED DUPLICATE of bug 961533
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 05:17 EDT by Vít Ondruch
Modified: 2013-06-01 22:44 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-01 22:44:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vít Ondruch 2013-05-15 05:17:46 EDT
Description of problem:

After update of Kernel, I've got following menuentry in /etc/grub2.cfg:

menuentry 'Fedora (3.9.1-301.fc19.x86_64) 19 (Schrödinger’s Cat)' --class fedora --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.9.0-301.fc19.x86_64-advanced-29a15114-4d0f-4139-be03-47e098da8da8' {
	load_video
	set gfxpayload=keep
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='hd0,msdos1'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1 --hint='hd0,msdos1'  dd4ad330-a3b4-4a94-9bcd-7f30ac5eddeb
	else
	  search --no-floppy --fs-uuid --set=root dd4ad330-a3b4-4a94-9bcd-7f30ac5eddeb
	fi
	echo 'Loading Fedora (3.9.1-301.fc19.x86_64) 19 (Schrödinger’s Cat)'
	linux	/vmlinuz-3.9.1-301.fc19.x86_64 root=UUID=29a15114-4d0f-4139-be03-47e098da8da8 ro rootflags=subvol=F19_-_root rd.md=0 rd.dm=0  rd.lvm.lv=vg_dhcp251/lv_swap_f17 rd.luks=0 vconsole.font=latarcyrheb-sun16 rd.lvm.lv=vg_dhcp251/lv_root_f19 vconsole.keymap=cz-lat2 rd.lvm.lv=vg_dhcp251/lv_swap_f18 rd.lvm.lv=vg_dhcp251/lv_swap_f19 rhgb quiet LANG=cs_CZ.UTF-8
	echo 'Loading initial ramdisk ...'
	initrd /initramfs-3.9.1-301.fc19.x86_64.img
}

Unfortunately, during boot the "Schrödinger's Cat" is messed up. It seems that the font used cannot handle the unicode characters properly.

Version-Release number of selected component (if applicable):
Fedora 19 Beta TC 4
$ rpm -q grub2
grub2-2.00-16.fc19.x86_64


How reproducible:
Always


Steps to Reproduce:
1. Install F19 Beta TC4
2. Update the Kernel go get the menu entry.
3. Reboot.
  
Actual results:
Wrongly displayed Schrödinger's Cat

Expected results:
Correctly displayed "Schrödinger's Cat"

Additional info:
Comment 1 Chris Murphy 2013-06-01 22:44:24 EDT

*** This bug has been marked as a duplicate of bug 961533 ***

Note You need to log in before you can comment on or make changes to this bug.