Bug 963202 - keymap can not be set after netboot text install
keymap can not be set after netboot text install
Status: CLOSED DUPLICATE of bug 1001411
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 07:32 EDT by Fabian Deutsch
Modified: 2013-09-29 14:09 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-29 14:09:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2013-05-15 07:32:53 EDT
Description of problem:
The keymap can not be set by using localectl

Version-Release number of selected component (if applicable):
F19 Alpha netboot image

How reproducible:


Steps to Reproduce:
1. Get image and launch a text mode installatio in vm and install system
2. Login to the console as root
3. run: localectl set-keymap de

4. run: cat /etc/vconsole.conf 
KEYMAP=de

5. run: localectl 
   System Locale: LANG=de_DE.UTF-8
       VC Keymap: de
      X11 Layout: de
       X11 Model: pc105
     X11 Options: terminate:ctrl_alt_bksp
6. Press "z" key, "y" appears on the screen - darn!

7. run loadkeys de
Lade /lib/kbd/keymaps/i386/qwertz/de.map.gz.

8. Press "z" key, "z" appears on the screen - wuhu!
  
Actual results:
Keymap can not be set using localectl

Expected results:


Additional info:
Comment 1 Harald Hoyer 2013-06-03 09:06:25 EDT
What is the output of:

# systemctl status systemd-vconsole-setup.service

after running 

# localectl set-keymap de

???

I think systemd only updates tty0 by restarting systemd-vconsole-setup.service.
If tty[1-9] are already used, they will not be updated by localectl.
Comment 3 Lennart Poettering 2013-09-29 14:03:03 EDT
What is the contents of /proc/cmdline?

(background: the kernel command line setting always overrides system config, hence you can set localectl as many times as you wish to set the locale settings, as long as something is written in /proc/cmdline to override it is ignore...)
Comment 4 Lennart Poettering 2013-09-29 14:09:47 EDT

*** This bug has been marked as a duplicate of bug 1001411 ***

Note You need to log in before you can comment on or make changes to this bug.