Bug 963209 - arptables option -x does not work together with -L
arptables option -x does not work together with -L
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: arptables_jf (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Jiri Popelka
Hubert Kario
: Patch
Depends On:
Blocks: 966520
  Show dependency treegraph
 
Reported: 2013-05-15 08:01 EDT by Hubert Kario
Modified: 2013-05-23 08:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause When command line option -x (exact values) is used along with -L (List rules) option. Consequence arptables program does not list rules but issues an error message saying that -x option is Illegal with -L. Fix A patch was applied. Result arptables program uses -x option when listing rules.
Story Points: ---
Clone Of:
: 966520 (view as bug list)
Environment:
Last Closed: 2013-05-21 04:17:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (946 bytes, patch)
2013-05-15 09:15 EDT, Jiri Popelka
no flags Details | Diff

  None (edit)
Description Hubert Kario 2013-05-15 08:01:45 EDT
Description of problem:
When trying to use -x option together with -L the command aborts with "Illegal option" error message

Version-Release number of selected component (if applicable):
arptables_jf-0.0.8-22.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. arptables -x -L
  
Actual results:
arptables v0.0.8: Illegal option `-x' with this command

Try `arptables -h' or 'arptables --help' for more information.

Expected results:
Listing of all rules with exact counter values

Additional info:
Comment 1 Jiri Popelka 2013-05-15 09:15:46 EDT
Created attachment 748283 [details]
patch
Comment 7 errata-xmlrpc 2013-05-21 04:17:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0843.html

Note You need to log in before you can comment on or make changes to this bug.