Bug 963225 - [Doc Bug Fix] Unclear prerequisite of JDK6 for RPM installation of EAP-6
[Doc Bug Fix] Unclear prerequisite of JDK6 for RPM installation of EAP-6
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.0.1
All Linux
unspecified Severity low
: ---
: EAP 6.4.0
Assigned To: Russell Dickenson
Russell Dickenson
: Documentation, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 08:42 EDT by Krain Arnold
Modified: 2015-07-16 20:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Instance Name: Not Defined Build: CSProcessor Builder Version 1.7 Build Name: 11862, Installation Guide-6-2 Build Date: 18-12-2012 17:07:28
Last Closed: 2015-07-16 20:40:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krain Arnold 2013-05-15 08:42:15 EDT
Description of problem: A listed prerequisite under the RPM installation section is: 

"A Java 6 JDK must be installed. If you wish to use a Java 7 JDK, you need to install both versions."

This seems to be based on the issue discussed in this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=900676

Namely, Open JDK7 does not provide "java" as an RPM dependency. The Oracle JDK for Java 7, however, does provide "java".

Suggestions for improvement: If the issue is limited to OpenJDK6, the prerequisite should be modified to articulate its applicability.
Comment 3 Pavel Janousek 2014-04-02 02:52:04 EDT
Based on current info from https://bugzilla.redhat.com/show_bug.cgi?id=1025791#c5, issue isn't fixed yet, so what about to close this BZ as duplication and track issue only in https://bugzilla.redhat.com/show_bug.cgi?id=1025791 if reporter agree?
Comment 4 Krain Arnold 2014-04-18 09:43:39 EDT
I have no issues consolidating, and for the most part I think https://bugzilla.redhat.com/show_bug.cgi?id=1025791 covers the issues. The only thing I would like to see clarified in that bug is that the issue seems limited to OpenJDK. Customers using Oracle JDK and reading the 6.2 installation guide will still see the warning: "A Java 6 JDK is required, even if you wish to use a Java 7 JDK". If that does not apply to Oracle users I would like to see that articulated in whichever bug we ultimately track this issue with.

Note You need to log in before you can comment on or make changes to this bug.