Bug 963298 - Module Service Dependencies do not take transitive dependencies into account
Module Service Dependencies do not take transitive dependencies into account
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: jbossas (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ER3
: EAP 6.1.1
Assigned To: Brad Maxwell
:
: 958849 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 11:29 EDT by Brad Maxwell
Modified: 2015-04-21 04:53 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
There existed an issue in JBoss EAP 6 where dependency graph resolution was not taking into account situations where the `Class-Path` specified in deployment manifests may be transitive. This would result in a module attempting to start before all its dependencies were started, and would cause the application to fail to deploy, resulting in the following exception: ---- Caused by: org.jboss.modules.ModuleLoadException: JBAS018760: Timeout waiting for module service: deployment.example.ear.example-ejb.jar:main ... ---- To fix this issue, a multi-stage resolution process was added to make sure that all dependent module specification services have started before starting a module service. As a result, a deployment should no longer fail where transitive dependencies are specified in its `Class-Path`.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 16:29:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-920 Major Resolved Module Service Dependencies do not take transitive dependencies into account 2015-04-23 06:17:42 EDT

  None (edit)
Description Brad Maxwell 2013-05-15 11:29:29 EDT
Module Service Dependencies do not take transitive dependencies into account 
https://issues.jboss.org/browse/WFLY-920

A ModuleLoadService has dependencies on all its dependent ModuleSpecServices, however this does not work if the ModuleSpecService has a dependency on another ModuleSpecService with export=true, as the module may attempt to load before transitive dependencies have been started.

This has caused transient failures in EarClassPathTransitiveClosureTestCase and causes "JBAS018760: Timeout waiting for module service" for a user with jars in ear/lib and many jars using Class-Path 

Caused by: org.jboss.modules.ModuleLoadException: JBAS018760: Timeout waiting for module service: deployment.test.ear.lib/generated/test.jar:main
  at org.jboss.as.server.moduleservice.ServiceModuleLoader$ModuleSpecLoadListener.getModuleSpec(ServiceModuleLoader.java:133) [jboss-as-server-7.1.3.Final-redhat-4.jar:7.1.3.Final-redhat-4]
  at org.jboss.as.server.moduleservice.ServiceModuleLoader.findModule(ServiceModuleLoader.java:174) [jboss-as-server-7.1.3.Final-redhat-4.jar:7.1.3.Final-redhat-4]
Comment 3 Brad Maxwell 2013-05-24 11:48:45 EDT
Flags have been updated, so we have 6.1.1 now, so changing proposal from 6.2 to 6.1.1 since this is a bug.
Comment 4 Jakub Cechacek 2013-08-07 04:29:59 EDT
Verified 6.1.1.ER4

EarClassPathTransitiveClosureTestCase passed
Comment 9 Enrique Gonzalez Martinez 2015-04-21 04:53:10 EDT
*** Bug 958849 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.