Bug 963326 - [RFE] Enhance installer logic
[RFE] Enhance installer logic
Status: CLOSED WONTFIX
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
4.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Fabian Deutsch
bugs@ovirt.org
node
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 12:23 EDT by Mike Burns
Modified: 2014-06-11 09:39 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-11 09:39:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2013-05-15 12:23:28 EDT
Description of problem:
Assuming I'm understanding the flow of the installer correctly...

Currently pages need to know what comes before or after in order to navigate correctly.  This leads to some limitations like plugins adding custom pages in custom locations in the installation flow.  It also means that adding a page in the core installer can cause some headaches since you have to edit both the page forward and the page back to make sure the flow is right.

A slightly different method for doing this would be a top level process that makes pages available to the user.  That top level page knows the order (in some method where a plugin could add a new page in between existing pages).  When the user completes a page, it returns a code like "forward" or "back" so the top level process knows to proceed to the next or return to the previous.
Comment 1 Doron Fediuck 2014-06-11 09:39:07 EDT
For oVirt 4.0 we may want a different node implementation.
Hence, closing this RFE. Please re-open if it becomes relevant.

Note You need to log in before you can comment on or make changes to this bug.