Bug 963336 - httpd fails to start on nodes due to missing mod_ssl dependency (enterprise 1.2)
httpd fails to start on nodes due to missing mod_ssl dependency (enterprise 1.2)
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jason DeTiberus
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 13:02 EDT by Tim Bielawa
Modified: 2013-06-11 00:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 00:03:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Bielawa 2013-05-15 13:02:42 EDT
Description of problem:
'service httpd start' fails on node hosts in enterprise-1.2

System was set up using the openshift-amz.sh script from openshift-extras enterprise-1.2 branch. Only the 'node' component selected.

Version-Release number of selected component (if applicable):
rubygem-openshift-origin-node-1.9.1-1.git.146.02cbfcd.el6op.noarch

> [root@node01 conf.d]# service httpd start
> Starting httpd: [Wed May 15 12:51:59 2013] [warn] module passenger_module is already loaded, skipping
> Syntax error on line 29 of /etc/httpd/conf.d/000001_openshift_origin_node.conf:
> Invalid command 'SSLEngine', perhaps misspelled or defined by a module not included in the server configuration
> [FAILED]


How reproducible:
100%

Steps to Reproduce:
1. Clone git://github.com/openshift/openshift-extras.git
2. Switch to enterprise-1.2 branch
3. Configure the necessary bits in enterprise/install-scripts/amazon/openshift-amz.sh
4. Only leave 'node' in $components
5. Run script
6. Reboot
  
Actual results:
httpd fails to start due to missing ssl module

Expected results:
httpd starts and loads the 000001_openshift_origin_node.conf config successfully.

Additional info:

Sending pull request with patch for node/rubygem-openshift-origin-node.spec presently
Comment 1 Tim Bielawa 2013-05-15 13:08:54 EDT
Pull request submitted:

https://github.com/openshift/origin-server/pull/2480
Comment 2 openshift-github-bot 2013-05-15 17:47:34 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/9d368abb2cf2e9bf21c7828c58b0c05bfec0a2c5
<rubygem-openshift-origin-node spec file> Bug 963336 - Add 'Requires'
of mod_ssl to fix httpd failing to start on node servers due to
missing ssl module required by 000001_openshift_origin_node.conf

Bugzilla link <https://bugzilla.redhat.com/show_bug.cgi?id=963336>
Comment 3 Johnny Liu 2013-05-20 05:25:06 EDT
Looks like this bug fix is already addressed, could you move it to "ON_QA".
Comment 4 Johnny Liu 2013-05-21 02:31:55 EDT
Verified this bug with rubygem-openshift-origin-node-1.9.2-1.git.96.6f0d5df.el6op.noarch, and PASS.

[root@node1 openshift]# yum deplist rubygem-openshift-origin-node-1.9.2-1.git.96.6f0d5df.el6op.noarch|grep mod_ssl
  dependency: mod_ssl
   provider: mod_ssl.x86_64 1:2.2.15-9.el6_1.2
   provider: mod_ssl.x86_64 1:2.2.15-15.el6_2.1
   provider: mod_ssl.x86_64 1:2.2.15-15.el6
   provider: mod_ssl.x86_64 1:2.2.15-9.el6_1.3
   provider: mod_ssl.x86_64 1:2.2.15-26.el6
   provider: mod_ssl.x86_64 1:2.2.15-9.el6
   provider: mod_ssl.x86_64 1:2.2.15-5.el6

Note You need to log in before you can comment on or make changes to this bug.