Bug 963359 - Shim should provide a mechanism for \EFI\BOOT\BOOTX64.EFI as a fallback on fixed media.
Shim should provide a mechanism for \EFI\BOOT\BOOTX64.EFI as a fallback on fi...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: shim (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
RejectedFreezeException
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 13:42 EDT by Peter Jones
Modified: 2013-07-08 21:29 EDT (History)
4 users (show)

See Also:
Fixed In Version: shim-0.4-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 21:29:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Jones 2013-05-15 13:42:37 EDT
Description of problem: When a machine's Boot#### and BootOrder are absent, for example due to a disk being moved to another machine or a wiped firmware, UEFI will attempt to treat fixed media as removable media, so that the installed OS can fix those variables itself.  Shim should provide a mechanism for doing this, but currently it does not do so.

Version-Release number of selected component (if applicable): 0.2
Comment 1 Adam Williamson 2013-05-15 13:55:35 EDT
Proposing as a freeze exception issue for Beta. Peter suggested blocker, but I'm not sure it's really significant enough for this; this is essentially a 'feature request' in that it should help in the case you move a UEFI install from system to system or something like that. It does seem like a change it'd be a good idea to get in for Beta to be tested.
Comment 2 Adam Williamson 2013-05-20 14:58:02 EDT
Discussed at 2013-05-20 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-20/f19beta-blocker-review-7.2013-05-20-16.07.log.txt . Rejected as a freeze exception issue as we're now close to Beta release and we really don't want to start poking shim for what is essentially a feature request; the chances of breaking stuff are too high.
Comment 3 Fedora Update System 2013-05-30 08:49:56 EDT
gnu-efi-3.0s-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnu-efi-3.0s-2.fc19
Comment 4 Fedora Update System 2013-06-07 17:31:23 EDT
shim-0.3-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/shim-0.3-2.fc19
Comment 5 Fedora Update System 2013-06-20 10:39:12 EDT
shim-0.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/shim-0.4-1.fc19
Comment 6 Fedora Update System 2013-06-20 10:39:18 EDT
shim-signed-0.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/shim-signed-0.4-1.fc19
Comment 7 Adam Williamson 2013-06-20 19:36:18 EDT
Note in case anyone thinks to bring this up: pjones says this build causes a minor issue with a bogus error message or something, and he doesn't think it should go in F19 Final, so unless something changes, I don't think we should make this FinalFE.
Comment 8 Peter Jones 2013-06-21 15:18:31 EDT
To clarify, this particular build has a bogus warning message on removable media.  So we probably don't want it in the final, as a) the feature it adds isn't useful on removable media, and b) it'll cause a warning there.  But it's fine for it to actually go in F19 updates, because install images won't be generated with an update, and we'd like people to actually get the feature when they install/update.
Comment 9 Fedora Update System 2013-07-08 21:29:29 EDT
shim-0.4-1.fc19, shim-signed-0.4-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.