Bug 963422 - firefox 21 disables plugins provided by other fedora packages by default
firefox 21 disables plugins provided by other fedora packages by default
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 14:42 EDT by David Juran
Modified: 2013-05-24 16:32 EDT (History)
3 users (show)

See Also:
Fixed In Version: firefox-21.0-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-18 22:39:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Juran 2013-05-15 14:42:48 EDT
Description of problem:
When starting firefox 21 for the first time, it pops up a dialog where the user must re-enable any plugins provided by other fedora packages such as mozvoikko. In my opionion, the default should be to leave at least fedora-provided plugins enabled.

Version-Release number of selected component (if applicable):
firefox-21.0-2.fc17
Comment 1 Martin Stransky 2013-05-16 04:06:58 EDT
Do you mean plugins and/or extensions? I don't see such behavior. There is a dialog for extensions only, which is not a bug, because of the FF update.
Comment 2 Remi Collet 2013-05-16 04:21:47 EDT
The "Select your Add-ons" dialog which show-up on first startup (after upgrade) propose to disables all "third party" extensiosn (and all packaged extensions are considered "third party").

This is especially annoying for current langpack for user locale which is also considered as third party.

As this dialog if not localized (by design, as displayed before extension loading), lot of non-english speaking user will not check the "keep" box.
Comment 3 Remi Collet 2013-05-16 04:32:15 EDT
Notice : RPM installed "after" upgrade (and a first run) are enabled, as previously.
Comment 4 Martin Stransky 2013-05-16 04:40:24 EDT
The problem is that we don't know which extensions are provided by Fedora packages. And extensions provided by Fedora packages can be outdated/incompatible as well as the ones installed by user from web.
Comment 5 Fedora Update System 2013-05-16 10:34:33 EDT
firefox-21.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/firefox-21.0-3.fc18
Comment 6 Fedora Update System 2013-05-16 10:34:44 EDT
firefox-21.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/firefox-21.0-3.fc19
Comment 7 Fedora Update System 2013-05-16 23:25:12 EDT
Package firefox-21.0-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firefox-21.0-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8390/firefox-21.0-3.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-05-18 22:39:48 EDT
firefox-21.0-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-05-24 16:32:17 EDT
firefox-21.0-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.