Bug 963472 - virt-manager missing a dependency avahi-tools
virt-manager missing a dependency avahi-tools
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 16:55 EDT by Igor Gnatenko
Modified: 2013-05-18 00:56 EDT (History)
6 users (show)

See Also:
Fixed In Version: virt-manager-0.10.0-0.4.gitb68faac8.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-18 00:56:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Gnatenko 2013-05-15 16:55:17 EDT
Description of problem:
At start virt-manager it asks:

The following packages are not installed:
avahi-tools

Yes or not.

I think that dependency avahi-tools need, because it looks for computers with libvirtd on a local network.

Version-Release number of selected component (if applicable):
virt-manager-0.10.0-0.3.gitb68faac8.fc19.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install Virtualization group
2. Start virt-manager
  
Actual results:
The following packages are not installed:
avahi-tools

Expected results:
avahi-tools automatically installed by virt-manager

Additional info:
Comment 1 Igor Gnatenko 2013-05-15 17:11:22 EDT
I think that this feature should be "out of box"
Comment 2 Cole Robinson 2013-05-15 17:39:33 EDT
sigh, this was some cruft left over from testing when I was messing around with this code. thanks for the report, build coming shortly
Comment 3 Fedora Update System 2013-05-15 17:49:00 EDT
virt-manager-0.10.0-0.4.gitb68faac8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/virt-manager-0.10.0-0.4.gitb68faac8.fc19
Comment 4 Igor Gnatenko 2013-05-15 17:50:32 EDT
(In reply to comment #2)
> sigh, this was some cruft left over from testing when I was messing around
> with this code. thanks for the report, build coming shortly
Why you doesn't added avahi-tools as requred?
> I think that dependency avahi-tools need, because it looks for computers with libvirtd on a local network.
Comment 5 Cole Robinson 2013-05-15 17:52:10 EDT
(In reply to comment #4)
> (In reply to comment #2)
> > sigh, this was some cruft left over from testing when I was messing around
> > with this code. thanks for the report, build coming shortly
> Why you doesn't added avahi-tools as requred?
> > I think that dependency avahi-tools need, because it looks for computers with libvirtd on a local network.

Because it isn't strictly required, and libvirt's avahi support is turned off by default anyways. And in fact I don't think we even need avahi-tools to talk to avahi over dbus, which is what virt-manager does.
Comment 6 Igor Gnatenko 2013-05-15 18:01:16 EDT
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #2)
> > > sigh, this was some cruft left over from testing when I was messing around
> > > with this code. thanks for the report, build coming shortly
> > Why you doesn't added avahi-tools as requred?
> > > I think that dependency avahi-tools need, because it looks for computers with libvirtd on a local network.
> 
> Because it isn't strictly required, and libvirt's avahi support is turned
> off by default anyways. And in fact I don't think we even need avahi-tools
> to talk to avahi over dbus, which is what virt-manager does.
Thanks for answers.
Comment 7 Fedora Update System 2013-05-16 01:23:13 EDT
Package virt-manager-0.10.0-0.4.gitb68faac8.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-0.10.0-0.4.gitb68faac8.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8323/virt-manager-0.10.0-0.4.gitb68faac8.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-05-18 00:56:19 EDT
virt-manager-0.10.0-0.4.gitb68faac8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.