This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 963503 - GError: Timeout was reached
GError: Timeout was reached
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
abrt_hash:e8ce3350b543f801baddae8c333...
:
Depends On:
Blocks: F19Beta/F19BetaBlocker
  Show dependency treegraph
 
Reported: 2013-05-15 21:45 EDT by Chris Murphy
Modified: 2013-05-18 00:54 EDT (History)
29 users (show)

See Also:
Fixed In Version: pykickstart-1.99.31-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-18 00:54:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (324.48 KB, text/plain)
2013-05-15 21:45 EDT, Chris Murphy
no flags Details
File: anaconda.log (1.21 KB, text/plain)
2013-05-15 21:45 EDT, Chris Murphy
no flags Details
File: backtrace (867 bytes, text/plain)
2013-05-15 21:45 EDT, Chris Murphy
no flags Details
File: environ (769 bytes, text/plain)
2013-05-15 21:45 EDT, Chris Murphy
no flags Details
File: lsblk_output (3.72 KB, text/plain)
2013-05-15 21:45 EDT, Chris Murphy
no flags Details
File: messages (216.77 KB, text/plain)
2013-05-15 21:46 EDT, Chris Murphy
no flags Details
File: nmcli_dev_list (3.44 KB, text/plain)
2013-05-15 21:46 EDT, Chris Murphy
no flags Details
File: program.log (11.82 KB, text/plain)
2013-05-15 21:46 EDT, Chris Murphy
no flags Details
File: storage.log (108.55 KB, text/plain)
2013-05-15 21:46 EDT, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2013-05-15 21:45:49 EDT
Description of problem:
Boot from Live beta TC4. Download updated anaconda 19.27-1, anaconda-widget, pykickstart, blivit, currently in bodhi, yum installed them, launched the installer. Crash on launch.
The following was filed automatically by anaconda:
anaconda 19.27-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
GError: Timeout was reached

Version-Release number of selected component:
anaconda-19.27-1.fc19.x86_64

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-Desktop-x86_64-19-Be ro rd.live.image quiet rhgb
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      21:41:47,904 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.0-301.fc19.x86_64
other involved packages: pygobject3-base-3.8.1-2.fc19.x86_64
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
ureports_counter: 1
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
GError: Timeout was reached
Comment 1 Chris Murphy 2013-05-15 21:45:52 EDT
Created attachment 748545 [details]
File: anaconda-tb
Comment 2 Chris Murphy 2013-05-15 21:45:55 EDT
Created attachment 748546 [details]
File: anaconda.log
Comment 3 Chris Murphy 2013-05-15 21:45:56 EDT
Created attachment 748547 [details]
File: backtrace
Comment 4 Chris Murphy 2013-05-15 21:45:58 EDT
Created attachment 748548 [details]
File: environ
Comment 5 Chris Murphy 2013-05-15 21:45:59 EDT
Created attachment 748549 [details]
File: lsblk_output
Comment 6 Chris Murphy 2013-05-15 21:46:01 EDT
Created attachment 748550 [details]
File: messages
Comment 7 Chris Murphy 2013-05-15 21:46:04 EDT
Created attachment 748551 [details]
File: nmcli_dev_list
Comment 8 Chris Murphy 2013-05-15 21:46:06 EDT
Created attachment 748552 [details]
File: program.log
Comment 9 Chris Murphy 2013-05-15 21:46:08 EDT
Created attachment 748553 [details]
File: storage.log
Comment 10 Chris Murphy 2013-05-15 22:03:36 EDT
1. Boot baremetal from Fedora-Live-Desktop-x86_64-19-Beta-TC4-1.iso USB stick media, which passes checksum and is known to at least launch the installer.

2. Launch Firefox, go to bodhi to find latest anaconda and deps to download from koji.

3. From Downloads folder: su -c 'yum install *' result in:

Updated:
  anaconda.x86_64 0:19.27-1.fc19                                                

Dependency Updated:
  anaconda-widgets.x86_64 0:19.27-1.fc19   pykickstart.noarch 0:1.99.31-1.fc19  
  python-blivet.noarch 0:0.14-1.fc19  
   

3. Launch installer from the big Welcome to Fedora window.

Crash.
Comment 11 satellitgo 2013-05-15 23:09:43 EDT
Description of problem:
start "livinst" in root terminal of sugar

Version-Release number of selected component:
anaconda-19.27-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-SoaS-x86_64-19-Beta- rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      23:07:40,178 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.1-301.fc19.x86_64
other involved packages: pygobject3-base-3.8.1-2.fc19.x86_64
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
GError: Timeout was reached
Comment 12 satellitgo 2013-05-15 23:27:40 EDT
Description of problem:
start livinst in root terminal

Version-Release number of selected component:
anaconda-19.27-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8 --xdriver=vesa
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-SoaS-x86_64-19-Beta- rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 xdriver=vesa nomodeset BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      23:23:49,076 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.1-301.fc19.x86_64
other involved packages: pygobject3-base-3.8.1-2.fc19.x86_64
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
GError: Timeout was reached
Comment 13 Adam Williamson 2013-05-16 00:19:16 EDT
Huh, I see this too with the Beta RC1 desktop live. A smoketest live image I built shortly before RC1 was fine. I'll compare the package sets.

I note the network connection seems to flip to 'connecting' then 'connected' very quickly during anaconda startup.
Comment 14 Adam Williamson 2013-05-16 00:20:07 EDT
Looks like a Beta blocker.
Comment 15 Adam Williamson 2013-05-16 00:21:13 EDT
[adamw@adam tmp]$ diff -u smoke.txt 19b_rc1.txt 
--- smoke.txt	2013-05-15 21:20:48.456134797 -0700
+++ 19b_rc1.txt	2013-05-15 21:18:01.618039938 -0700
@@ -71,8 +71,8 @@
 brasero-libs-3.8.0-1.fc19.x86_64
 brasero-nautilus-3.8.0-1.fc19.x86_64
 bridge-utils-1.5-7.fc19.x86_64
-brlapi-0.6.0-5.fc19.x86_64
-brltty-4.5-5.fc19.x86_64
+brlapi-0.6.0-4.fc19.x86_64
+brltty-4.5-4.fc19.x86_64
 btparser-0.25-2.fc19.x86_64
 btrfs-progs-0.20.rc1.20130308git704a08c-1.fc19.x86_64
 bzip2-1.0.6-8.fc19.x86_64
@@ -304,7 +304,7 @@
 gnome-session-xsession-3.8.2-1.fc19.x86_64
 gnome-settings-daemon-3.8.2-1.fc19.x86_64
 gnome-settings-daemon-updates-3.8.2-1.fc19.x86_64
-gnome-shell-3.8.2-1.fc19.x86_64
+gnome-shell-3.8.2-2.fc19.x86_64
 gnome-system-log-3.8.1-1.fc19.x86_64
 gnome-system-monitor-3.8.2-1.fc19.x86_64
 gnome-terminal-3.8.2-1.fc19.x86_64
@@ -947,7 +947,7 @@
 pytalloc-2.0.8-2.fc19.x86_64
 python-2.7.4-4.fc19.x86_64
 python3-3.3.1-4.fc19.x86_64
-python3-brlapi-0.6.0-5.fc19.x86_64
+python3-brlapi-0.6.0-4.fc19.x86_64
 python3-cairo-1.10.0-5.fc19.x86_64
 python3-gobject-3.8.1-2.fc19.x86_64
 python3-libs-3.3.1-4.fc19.x86_64
Comment 16 Adam Williamson 2013-05-16 00:23:55 EDT
so it looks like we forgot to pull the latest brltty into Beta RC1 (it's one of the many space fixes), and I forgot to pull the latest gnome-shell into my smoketest. But if this is happening with SoaS too, gnome-shell doesn't seem like a suspect. Weird.
Comment 17 Adam Williamson 2013-05-16 00:24:47 EDT
When I run 'liveinst' as a regular user on the Beta RC1 images, I get an error about connecting to the X server and a huge pile of GTK errors. When I run it on my smoketest image, no console errors at all. It looks like something somewhere went wonky with the RC1 compose?
Comment 18 Adam Williamson 2013-05-16 00:47:06 EDT
This seems to be to do with SELinux, somehow. For me, if I run 'setenforce Permissive' first, liveinst works.
Comment 19 Adam Williamson 2013-05-16 00:55:09 EDT
well, this is getting weird. bcl says to assign it to rvykydal, anyway. It may not be selinux after all, I'm getting weird, different results in multiple tests. it may be a timing thing of some kind. bcl reports that boot.iso fails on the same traceback.
Comment 20 Adam Williamson 2013-05-16 01:00:43 EDT
Suddenly, now, I can't reproduce this. I just did five boots in a row and it worekd all five times. Maybe we were all hitting some kind of failure case in the geoip stuff which is related to conditions on the remote end, and that went away?
Comment 21 Adam Williamson 2013-05-16 01:08:59 EDT
So yeah, for a few minutes bcl, satellit and myself were all hitting this, then it suddenly went away, and now I can't reproduce it at all. boot.iso and live install start up fine every time for me right now. My money is on something in the geolocation stuff.
Comment 22 Igor Gnatenko 2013-05-16 02:04:24 EDT
Description of problem:
Start from "test install media and install"
Press  ESC in process.
Maybe troubleshot in emulate CPU in KVM. (use "copy cpu from host machine")

Version-Release number of selected component:
anaconda-19.27-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      06:01:40,582 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.1-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
GError: Timeout was reached
Comment 23 Harish Pillay 2013-05-16 02:13:20 EDT
Description of problem:
was trying to install into the VM from the live CD.

Version-Release number of selected component:
anaconda-19.27-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-MATE-Compiz-x86_64-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      02:11:28,690 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.1-301.fc19.x86_64
other involved packages: pygobject3-base-3.8.1-2.fc19.x86_64
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
GError: Timeout was reached
Comment 24 Andre Robatino 2013-05-16 03:12:58 EDT
Description of problem:
Booted the 19 Beta RC1 i386 netinst

Version-Release number of selected component:
anaconda-19.27-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20i386 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      07:10:22,936 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.1-301.fc19.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
  File "/usr/lib/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/usr/lib/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
GError: Timeout was reached
Comment 25 Andre Robatino 2013-05-16 03:19:12 EDT
Description of problem:
Booted the 19 Beta RC1 x86_64 netinst

Version-Release number of selected component:
anaconda-19.27-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      07:17:17,786 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.1-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
GError: Timeout was reached
Comment 26 Tao Wu 2013-05-16 03:58:02 EDT
Description of problem:
Boot the F19 Beta RC1 netinst ov kvm, and it crashed at the begining.

Version-Release number of selected component:
anaconda-19.27-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20i386 rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      07:56:09,913 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.1-301.fc19.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
  File "/usr/lib/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/usr/lib/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
GError: Timeout was reached
Comment 27 Jan Sedlák 2013-05-16 05:29:45 EDT
Description of problem:
Booted into Fedora 18 Beta RC1 desktop.

Version-Release number of selected component:
anaconda-19.27-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-Be rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      05:27:28,357 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.1-301.fc19.x86_64
other involved packages: pygobject3-base-3.8.1-2.fc19.x86_64
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
GError: Timeout was reached
Comment 28 Martin Krizek 2013-05-16 05:50:31 EDT
I'd like to note that it seems that it only crashes the first time anaconda is run, following runs work fine (tested with live image obviously).
Comment 29 Radek Vykydal 2013-05-16 06:26:16 EDT
Patch sent for review.

Updates image for anaconda 19.27:
http://rvykydal.fedorapeople.org/updates.gerror.img

Please note that getting updates image from network will in most cases spoil the reproducer but you can use e.g. updates=hd:sdb1:/updates.img with netinst on USB
Comment 30 MartinKG 2013-05-16 07:56:16 EDT
Description of problem:
try to install Fedora 19 Beta RC1 on win7 guest with VMWare 9.0.2

Version-Release number of selected component:
anaconda-19.27-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      13:52:44,232 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.1-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
GError: Timeout was reached
Comment 31 Clemens Eisserer 2013-05-16 08:18:34 EDT
Description of problem:
clicked on install-to-harddrive icon on desktop

Version-Release number of selected component:
anaconda-19.27-1.fc19.i686

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=/ubninit root=UUID=0680-B55F rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 BOOT_IMAGE=/ubnkern 
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      10:15:49,455 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.1-301.fc19.i686
other involved packages: pygobject3-base-3.8.1-2.fc19.i686
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
  File "/usr/lib/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/usr/lib/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
GError: Timeout was reached
Comment 32 satellitgo 2013-05-16 08:20:35 EDT
(In reply to comment #28)
> I'd like to note that it seems that it only crashes the first time anaconda
> is run, following runs work fine (tested with live image obviously).

I also see this with Fedora-Live-Desktop-x86_64-19-Beta-1.iso

failure on first try; and works most times on repeat  - on bare metal
also did reformat of the usb HD prior to install to HD in live
Comment 33 Jaroslav Reznik 2013-05-16 08:38:21 EDT
Guys, could you retry it with the updates.gerror.img - https://bugzilla.redhat.com/show_bug.cgi?id=963503#c29?
Comment 34 satellitgo 2013-05-16 09:05:22 EDT
Description of problem:
boot netinstall beta RC1

Version-Release number of selected component:
anaconda-19.27-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      13:03:36,686 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.1-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
GError: Timeout was reached
Comment 35 John Reiser 2013-05-16 09:20:53 EDT
Description of problem:
boot Fedora-19-Beta-i386-netinst.iso (RC1) from CD with inst.stage2=hd:UUID=<<UID_of_USB_flash>> where USB flash is livecd-iso-to-disk of corresponding full install DVD.

Version-Release number of selected component:
anaconda-19.27-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:UUID=C047-E250 BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      13:17:47,509 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.1-301.fc19.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
  File "/usr/lib/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/usr/lib/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
GError: Timeout was reached
Comment 36 satellitgo 2013-05-16 11:02:31 EDT
(In reply to comment #32)
> (In reply to comment #28)
> > I'd like to note that it seems that it only crashes the first time anaconda
> > is run, following runs work fine (tested with live image obviously).
> 
> I also see this with Fedora-Live-Desktop-x86_64-19-Beta-1.iso
> 
> failure on first try; and works most times on repeat  - on bare metal
> also did reformat of the usb HD prior to install to HD in live

note the retry is much easier if "liveinst" in root terminal is used.
Repeat by using up arrow in terminal.
Comment 37 John Reiser 2013-05-16 11:35:20 EDT
The updates.gerror.img of Comment #29 worked for me: install started and completed successfully.
Comment 38 Fedora Update System 2013-05-16 12:16:20 EDT
pykickstart-1.99.31-1.fc19, anaconda-19.28-1.fc19, python-blivet-0.14-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-8322/python-blivet-0.14-1.fc19,pykickstart-1.99.31-1.fc19,anaconda-19.28-1.fc19
Comment 39 Bhushan Karia 2013-05-16 14:56:28 EDT
Description of problem:
I have downloaded Fedora 19 RC1 ISO DVD and just started installation and got this error.

Version-Release number of selected component:
anaconda-19.27-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20i386 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      00:15:57,473 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.1-301.fc19.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
  File "/usr/lib/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/usr/lib/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
GError: Timeout was reached
Comment 40 David W. Legg 2013-05-16 15:29:42 EDT
Description of problem:
Updated to latest anaconda within KDE live fc19 alpha.
Did install to disk.
Reported unknwon error.

Version-Release number of selected component:
anaconda-19.27-1.fc19.i686

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-KDE-i686-19-Alpha-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      15:26:09,732 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.0-0.rc6.git2.3.fc19.i686
other involved packages: pygobject3-base-3.8.0-2.fc19.i686
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
ureports_counter: 1
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
  File "/usr/lib/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/usr/lib/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
GError: Timeout was reached
Comment 41 Robert Lightfoot 2013-05-16 16:37:02 EDT
Description of problem:
Booting Fedora-Beta-RC1-i386-DVD.iso to attempt install

Version-Release number of selected component:
anaconda-19.27-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20i386 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      20:34:09,326 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.1-301.fc19.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
  File "/usr/lib/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/usr/lib/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
GError: Timeout was reached
Comment 42 Robert Lightfoot 2013-05-16 16:41:01 EDT
Description of problem:
Booting Fedora-19-Beta-RC1-X86_64 to attempt install

Version-Release number of selected component:
anaconda-19.27-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      20:39:27,230 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.1-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
GError: Timeout was reached
Comment 43 Robert Lightfoot 2013-05-16 16:55:17 EDT
udates.gerror.img appears to work for Beta-RC1-DVD.iso on my test farm.
Comment 44 Alexei Panov 2013-05-16 16:58:24 EDT
Description of problem:
I try to install from Fedora 19 x86_64 Beta RC1 netinstall image

Version-Release number of selected component:
anaconda-19.27-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      20:56:44,396 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.1-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
GError: Timeout was reached
Comment 45 Kevin Fenzi 2013-05-16 17:24:15 EDT
Clear blocker, IMHO. +1 blocker.
Comment 46 Dennis Gilmore 2013-05-16 17:25:12 EDT
+1 to blocker from me
Comment 48 Igor Gnatenko 2013-05-16 17:28:02 EDT
+1 Beta Blocker
Comment 49 Adam Williamson 2013-05-16 17:38:45 EDT
Thanks folks, that's enough: setting AcceptedBlocker.
Comment 50 Peter Kotvan 2013-05-17 05:19:37 EDT
Description of problem:
I've tried to install f19 RC1 image in virtual machine.

I've selected install Fedora 19-Beta in bootloader.

This error window appeared right after start of anaconda, without any user input.

I've system was connected to the network (checked with ping).

Version-Release number of selected component:
anaconda-19.27-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20i386 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      09:02:23,293 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.1-301.fc19.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
  File "/usr/lib/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/usr/lib/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
GError: Timeout was reached
Comment 51 Martin Krizek 2013-05-17 06:31:16 EDT
I don't see this on F19 Beta RC2.
Comment 52 Elad Alfassa 2013-05-17 11:35:29 EDT
Description of problem:
Started anaconda on F19 RC1 Live in gnome-boxes, expected to be able to install the system.

Version-Release number of selected component:
anaconda-19.27-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-Be rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      11:32:43,802 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.1-301.fc19.x86_64
other involved packages: pygobject3-base-3.8.1-2.fc19.x86_64
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1040, in <module>
    networkInitialize(ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 882, in networkInitialize
    if dumpMissingDefaultIfcfgs():
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 318, in dumpMissingDefaultIfcfgs
    nm.nm_update_settings_of_device(devname, 'connection', 'id', devname)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 414, in nm_update_settings_of_device
    return _update_settings(_device_settings(name), key1, key2, value, default_type_str)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 436, in _update_settings
    None)
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
GError: Timeout was reached
Comment 53 Andre Robatino 2013-05-17 18:05:22 EDT
Appears fixed in 19 Beta RC2 (tested the install images).
Comment 54 Fedora Update System 2013-05-17 18:18:45 EDT
Package pykickstart-1.99.31-1.fc19, anaconda-19.28-1.fc19, python-blivet-0.14-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pykickstart-1.99.31-1.fc19 anaconda-19.28-1.fc19 python-blivet-0.14-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8322/python-blivet-0.14-1.fc19,pykickstart-1.99.31-1.fc19,anaconda-19.28-1.fc19
then log in and leave karma (feedback).
Comment 55 Fedora Update System 2013-05-18 00:54:38 EDT
pykickstart-1.99.31-1.fc19, anaconda-19.28-1.fc19, python-blivet-0.14-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.