Bug 963514 - Cannot create snapshot ,Unable to find cgroup for vm
Cannot create snapshot ,Unable to find cgroup for vm
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.4
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Libvirt Maintainers
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 23:02 EDT by xingxing
Modified: 2013-05-23 05:08 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 06:16:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xingxing 2013-05-15 23:02:58 EDT
Description of problem:
After cgconfig service restarted and libvirtd restarted ,could not create snapshot for vm.

Version-Release number of selected component (if applicable):
# uname -r
2.6.32-358.6.1.el6.x86_64
# rpm -q libvirt
libvirt-0.10.2-18.el6_4.4.x86_64
# rpm -q qemu-kvm-rhev
qemu-kvm-rhev-0.12.1.2-2.355.el6.3.x86_64


How reproducible:
100%

Steps to Reproduce:
1.service cgconfig restart
2.service libvirtd restart
3.virsh snapshot-create-as testvm s1 --disk-only
  
Actual results:
error: internal error Unable to find cgroup for cho2013051600036
in libvirtd.log:
2013-05-16 02:53:02.062+0000: 16157: error : qemuDomainSnapshotCreateDiskActive:11299 : internal error Unable to find cgroup for testvm
in /cgroup there no cgroup config for testvm.

Expected results:
create snapshot success.

Additional info:
Comment 1 xingxing 2013-05-15 23:05:36 EDT
cho2013051600036 is another vm's name ,the error message is:
error: internal error Unable to find cgroup for testvm
Comment 3 Jiri Denemark 2013-05-20 06:16:42 EDT
I don't think restarting cgconfig service is something we want to support unless there's a real reason for doing that. If you restart cgconfig service, all cgroups are removed and all tasks are moved to the root cgroup.

I'm closing this as not a bug, but feel free to reopen if there is a real situation in which cgconfig service needs to be restarted.
Comment 4 Daniel Berrange 2013-05-20 06:27:09 EDT
If anything this is really broken behaviour of cgconfig. Nothing should ever unilaterally delete the cgroups hierarchy once the system has booted.

Note You need to log in before you can comment on or make changes to this bug.