Bug 963518 - library version mismatch between brms-p-5.3.1.GA-deployable-ee6 and EAP6
library version mismatch between brms-p-5.3.1.GA-deployable-ee6 and EAP6
Status: CLOSED NOTABUG
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Build and Assembly (Show other bugs)
5.x.x
Unspecified Unspecified
unspecified Severity medium
: ER1
: ---
Assigned To: Julian Coleman
Radovan Synek
:
: 963519 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 23:14 EDT by Toshiya Kobayashi
Modified: 2013-10-22 10:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 963516
Environment:
Last Closed: 2013-10-22 10:03:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshiya Kobayashi 2013-05-15 23:14:39 EDT
I have cloned this BZ from BRMS 5.3.1 for the same concern about packaging BPMS 6

+++ This bug was initially created as a clone of Bug #963516 +++

For instance, brms-p-5.3.1.GA-deployable-ee6 includes hibernate-core-3.3.2.GA.jar but JBoss EAP 6.0.0 includes hibernate-core-4.1.3.Final-redhat-1.jar and JBoss EAP 6.0.1 includes hibernate-core-4.1.6.Final-redhat-3.jar.

I'm under impression that brms-p-5.3.1.GA-deployable-ee6 should provide the same version jars as EAP 6 so that users can test with those jars and then deploy the application on EAP 6.

Actually, if I run jBPM5+JPA2 with jars under brms-p-5.3.1.GA-deployable-ee6/jboss-jbpm-engine/lib, I get the following Exception:

====
org.xml.sax.SAXParseException: cvc-complex-type.3.1: Value '2.0' of attribute 'version' of element 'entity-mappings' is not valid with respect to the corresponding attribute use. Attribute 'version' has a fixed value of '1.0'.
====

which was fixed in hibernate 3.5.6.

https://hibernate.atlassian.net/browse/HHH-5310 

If I switched hibernate libraries to ones in EAP 6.0.1 (hibernate 4.1.6) and it seems to work fine. (Attached an example project)

I confirmed with Lukas that jBPM5+JPA2 is supported/tested with EAP 6. So brms-p-5.3.1.GA-deployable-ee6 should be fixed.

--- Additional comment from Toshiya Kobayashi on 2013-05-15 23:10:07 EDT ---

Created attachment 748567 [details]
jBPMEx81_getTasksAssignedAsPotentialOwner_GroupId_JPA2.zip
Comment 2 Ryan Zhang 2013-06-14 03:00:26 EDT
This issue might not be appliable or have alrealy been fixed in BPMS6.
 Both product-depolyable or product-eap6 distribution is not using the old hibernate version anymore.
Comment 3 Ryan Zhang 2013-06-14 03:01:10 EDT
*** Bug 963519 has been marked as a duplicate of this bug. ***
Comment 4 Radovan Synek 2013-10-22 10:03:19 EDT
This should not be an issue for BRMS/BPMS 6, because all libraries should be available as EAP modules.

Note You need to log in before you can comment on or make changes to this bug.