Bug 963546 - Hypervisor is unassigned after upgrade
Hypervisor is unassigned after upgrade
Status: CLOSED DUPLICATE of bug 962180
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.2
All All
urgent Severity urgent
: ---
: 3.2.3
Assigned To: Roy Golan
infra
:
: 966957 (view as bug list)
Depends On:
Blocks: 902971
  Show dependency treegraph
 
Reported: 2013-05-16 02:37 EDT by Pavel Zhukov
Modified: 2016-02-10 14:17 EST (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-12 11:25:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Zhukov 2013-05-16 02:37:20 EDT
Description of problem:
After hypervisor upgrading and changing name of ISCSI initiator (because of the bug) hypervisor goes to Unassigned state for a long time. Now way to change status.

Version-Release number of selected component (if applicable):
rhevm-3.1.0-50.el6ev.noarch 
Red Hat Enterprise Virtualization Hypervisor release 6.4 (20130415.0.el6_4)

How reproducible:
Unkonow (WIP)

Steps to Reproduce:
1. Updagrade hypervisor (RHEV UI)
2. Change ISCSI initiator name to something wrong
3. Boot hypervisor => NonOperational
4. Change ISCSI initiator name
5. Host goes to unassigned state and never to NonOperational or UP
  
Expected results:
Non-Operational or UP state, possibility to put host to Maintenance

Additional info:
After last reboot looks like host has un-syncronized networks.It was about 2 weeks between steps 3 and 4
Comment 7 Yaniv Bronhaim 2013-05-19 08:20:01 EDT
Pavel, Host in unassigned mode always move to non-operational or connecting when the host is reachable, this state is a temporary state before moving the host to up, if it can't move to up it should return to non-operational. 
Just to clarify the description, your host was non-operational, then you changed back the initiator name, automatically after period of time the status was changed to unassigned and got stuck there?
Comment 8 Pavel Zhukov 2013-05-19 15:42:08 EDT
Yaniv, 
Yes, You're right. Host went to unassigned state and got stuck there for a long time (20hrs at least).
Comment 14 Barak 2013-06-06 08:47:37 EDT
Douglas
- can you please try it with the exact versions described above ?
- In addition go over the logs and see if you can find any reference to a reason for that to happen.
Comment 15 Douglas Schilling Landgraf 2013-06-06 08:55:09 EDT
(In reply to Barak from comment #14)
> Douglas
> - can you please try it with the exact versions described above ?
> - In addition go over the logs and see if you can find any reference to a
> reason for that to happen.

Sure.
Comment 22 Simon Grinberg 2013-06-17 07:45:46 EDT
*** Bug 966957 has been marked as a duplicate of this bug. ***
Comment 31 Pavel Zhukov 2013-07-23 06:58:38 EDT
Reproduced at home. 

Host is in Maintenance state -> Try to activate it (with missed network or ISO domain) -> Non-Operational (as expected) -> Fix the reason of Non-Operational state -> Activate -> Host (sometimes!) gets stuck in unassigned state. Restart ovirt-engine helps.

Note You need to log in before you can comment on or make changes to this bug.