Bug 963579 - `subscription-manager environments` does not recognize Library as an env.
`subscription-manager environments` does not recognize Library as an env.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: rc
: 7.0
Assigned To: Devan Goodwin
Garik Khachikyan
: Triaged
: 1077246 (view as bug list)
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2013-05-16 03:58 EDT by Garik Khachikyan
Modified: 2015-01-04 16:59 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:39:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garik Khachikyan 2013-05-16 03:58:44 EDT
Description of problem:
Doing an implementation of making Library as an environment too please fix to have it listed for RHSM environments command too. thanks.
Right now:
---
subscription-manager environments --username admin --password <secret> --org ACME_Corporation
Error: This org does not have environments.
---

Version-Release number of selected component (if applicable):
candlepin-0.8.7-1.el6.noarch
candlepin-cert-consumer-cfseserver4.usersys.redhat.com-1.0-1.noarch
candlepin-selinux-0.8.7-1.el6.noarch
candlepin-tomcat6-0.8.7-1.el6.noarch
elasticsearch-0.19.9-7.el6.noarch
katello-1.4.2-1.git.352.c97daf2.el6.noarch
katello-all-1.4.2-1.git.352.c97daf2.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-cli-1.4.2-1.git.48.441089b.el6.noarch
katello-cli-common-1.4.2-1.git.48.441089b.el6.noarch
katello-common-1.4.2-1.git.352.c97daf2.el6.noarch
katello-configure-1.4.3-1.git.21.0134f7d.el6.noarch
katello-glue-candlepin-1.4.2-1.git.352.c97daf2.el6.noarch
katello-glue-elasticsearch-1.4.2-1.git.352.c97daf2.el6.noarch
katello-glue-pulp-1.4.2-1.git.352.c97daf2.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-repos-1.4.2-1.el6.noarch
katello-selinux-1.4.3-1.git.3.ce8227b.el6.noarch
m2crypto-0.21.1.pulp-8.el6.x86_64
mod_wsgi-3.4-1.pulp.el6.x86_64
pulp-rpm-plugins-2.1.1-0.10.beta.el6.noarch
pulp-selinux-2.1.1-0.10.beta.el6.noarch
pulp-server-2.1.1-0.10.beta.el6.noarch
python-isodate-0.5.0-1.pulp.el6.noarch
python-oauth2-1.5.170-3.pulp.el6.noarch
python-pulp-common-2.1.1-0.10.beta.el6.noarch
python-pulp-rpm-common-2.1.1-0.10.beta.el6.noarch
python-qpid-0.14-11.el6_3.noarch
python-rhsm-1.8.0-1.pulp.el6.x86_64
qpid-cpp-client-0.14-22.el6_3.x86_64
qpid-cpp-client-ssl-0.14-22.el6_3.x86_64
qpid-cpp-server-0.14-22.el6_3.x86_64
qpid-cpp-server-ssl-0.14-22.el6_3.x86_64
ruby193-rubygem-ldap_fluff-0.1.3-4.el6.noarch
signo-katello-0.0.9-1.el6.noarch

How reproducible:
always on today's nightly.

Steps to Reproduce:
1.sync a repo (no promotions to any environments, no env. creation)
2. do subscription-manager environments
3.
  
Actual results:
error: no env found

Expected results:
Library is an environment 

Additional info:
Comment 3 Bryan Kearney 2013-07-19 14:54:01 EDT
This is returned now which I think is valid:

[root@bkearney ~]# subscription-manager environments
Username: admin
Password: 
Error: Server does not support environments.


[root@bkearney ~]# rpm -qa | grep subsc
subscription-manager-1.8.13-1.git.1.ba56998.fc18.x86_64
subscription-manager-gui-1.8.13-1.git.1.ba56998.fc18.x86_64
Comment 4 Garik Khachikyan 2013-10-15 09:55:02 EDT
@ Bryan: I believe your subscription manager is not tuned to Satellite6 but to CDN.

# REOPEN
no fix seems.

I still see:
---
[root@demeter ~]# subscription-manager environments
Username: admin
Password: 
Organization: ACME_Corporation
Error: This org does not have environments.

versions:
===
subscription-manager-1.8.22-1.el6_4.x86_64
+
candlepin-0.8.25-1.el6sam.noarch
candlepin-cert-consumer-demeter.usersys.redhat.com-1.0-1.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.25-1.el6sam.noarch
candlepin-tomcat6-0.8.25-1.el6sam.noarch
createrepo-0.9.9-21.2.pulp.el6sat.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-1.4.6-31.el6sat.noarch
katello-agent-1.4.4-3.el6sat.noarch
katello-all-1.4.6-31.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-cli-1.4.3-20.el6sat.noarch
katello-cli-common-1.4.3-20.el6sat.noarch
katello-common-1.4.6-31.el6sat.noarch
katello-configure-1.4.7-3.el6sat.noarch
katello-configure-foreman-1.4.7-3.el6sat.noarch
katello-configure-foreman-proxy-1.4.7-3.el6sat.noarch
katello-foreman-all-1.4.6-31.el6sat.noarch
katello-glue-candlepin-1.4.6-31.el6sat.noarch
katello-glue-elasticsearch-1.4.6-31.el6sat.noarch
katello-glue-pulp-1.4.6-31.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-selinux-1.4.4-4.el6sat.noarch
m2crypto-0.21.1.pulp-8.el6sat.x86_64
mod_wsgi-3.4-1.pulp.el6sat.x86_64
pulp-katello-plugins-0.2-1.el6sat.noarch
pulp-nodes-common-2.3.0-0.17.beta.el6sat.noarch
pulp-nodes-parent-2.3.0-0.17.beta.el6sat.noarch
pulp-puppet-plugins-2.3.0-0.17.beta.el6sat.noarch
pulp-rpm-handlers-2.3.0-0.17.beta.el6sat.noarch
pulp-rpm-plugins-2.3.0-0.17.beta.el6sat.noarch
pulp-selinux-2.3.0-0.17.beta.el6sat.noarch
pulp-server-2.3.0-0.17.beta.el6sat.noarch
python-isodate-0.5.0-1.pulp.el6sat.noarch
python-oauth2-1.5.170-3.pulp.el6sat.noarch
python-pulp-agent-lib-2.3.0-0.17.beta.el6sat.noarch
python-pulp-bindings-2.3.0-0.17.beta.el6sat.noarch
python-pulp-common-2.3.0-0.17.beta.el6sat.noarch
python-pulp-puppet-common-2.3.0-0.17.beta.el6sat.noarch
python-pulp-rpm-common-2.3.0-0.17.beta.el6sat.noarch
python-qpid-0.18-5.el6_4.noarch
qpid-cpp-client-0.14-22.el6_3.x86_64
qpid-cpp-client-ssl-0.14-22.el6_3.x86_64
qpid-cpp-server-0.14-22.el6_3.x86_64
qpid-cpp-server-ssl-0.14-22.el6_3.x86_64
ruby193-rubygem-foreman-katello-engine-0.0.14-5.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.7-2.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
signo-katello-0.0.22-2.el6sat.noarch
Comment 5 Devan Goodwin 2013-10-22 08:33:20 EDT
I can remove for RHEL 7, unfortunately there's not really anything we can do for all released versions of RHEL, this was done directly in subscription-manager and we'll have to support it / live with it as such.
Comment 7 John Sefler 2013-10-29 09:21:07 EDT
This bug contradicts bug 795541 which explicitly filters out the "Library" by design.
Comment 8 Devan Goodwin 2013-11-01 11:43:02 EDT
Fixed in subscription-manager.git master 60ef4ff2339029536a9552f612b90bdb60b57832. Will appear in subscription-manager-1.10.6-1
Comment 10 spandey 2013-11-08 07:09:34 EST
Verified Using Rhel 7 with  following rpm  

subscription-manager-firstboot-1.10.6-1.el7.x86_64
subscription-manager-migration-data-2.0.5-1.git.0.3be2ad4.el7.noarch
subscription-manager-1.10.6-1.el7.x86_64
subscription-manager-gui-1.10.6-1.el7.x86_64
subscription-manager-migration-1.10.6-1.el7.x86_64


[root@localhost sm]# subscription-manager environments
Username: admin
Password: 
Organization: redhat
+-------------------------------------------+
          Environments
+-------------------------------------------+
Name:        Library
Description: None



root@localhost sm]# subscription-manager identity
system identity: e1cfcdad-6800-4d01-b43f-a0a9a1e1b95a
name: localhost.localdomain
org name: redhat
org ID: redhat
environment name: Library

working fine resolving defect as verified
Comment 11 Bryan Kearney 2014-03-19 16:23:40 EDT
*** Bug 1077246 has been marked as a duplicate of this bug. ***
Comment 12 Ludek Smid 2014-06-13 06:39:11 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.