Bug 963590 - Full introspection support for QMP: query-qmp-schema
Full introspection support for QMP: query-qmp-schema
Status: CLOSED DUPLICATE of bug 557939
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Amos Kong
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 04:18 EDT by Amos Kong
Modified: 2015-05-24 20:07 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-16 08:31:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amos Kong 2013-05-16 04:18:10 EDT
One important feature for QMP in 1.6 is full introspection support.

By that we mean having a command like query-qmp-schema which returns the contents of qapi-schema.json in json format. The query-command-line-options command is a simple example of such a command.

qapi-schema.json is processed by qapi python scripts to generate C
files, I found the content is good enough for Libvirt to know the
QMP command schema. We can change qapi scripts to generate a talbe/list
to record the raw string, then we can return the raw string in
qmp_query_qmp_schema().
Comment 1 Luiz Capitulino 2013-05-16 08:31:18 EDT
Amos, it turns out that we already have a BZ for this. I'm going to close this one as a dupe and re-assign the original one to you. Feel free to add new information as a comment.

*** This bug has been marked as a duplicate of bug 557939 ***

Note You need to log in before you can comment on or make changes to this bug.