Bug 963599 - [abrt] cinnamon-1.8.2-4.fc19: object_instance_finalize: Process /usr/bin/cinnamon was killed by signal 5 (SIGTRAP)
[abrt] cinnamon-1.8.2-4.fc19: object_instance_finalize: Process /usr/bin/cinn...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cinnamon (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
abrt_hash:69481444af4e83c73330ef2b742...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 04:27 EDT by Tomas Dolezal
Modified: 2013-07-13 23:31 EDT (History)
18 users (show)

See Also:
Fixed In Version: cinnamon-1.9.1-16.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-13 23:31:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (40.22 KB, text/plain)
2013-05-16 04:27 EDT, Tomas Dolezal
no flags Details
File: cgroup (142 bytes, text/plain)
2013-05-16 04:27 EDT, Tomas Dolezal
no flags Details
File: core_backtrace (1.61 KB, text/plain)
2013-05-16 04:28 EDT, Tomas Dolezal
no flags Details
File: dso_list (20.26 KB, text/plain)
2013-05-16 04:28 EDT, Tomas Dolezal
no flags Details
File: environ (1.35 KB, text/plain)
2013-05-16 04:28 EDT, Tomas Dolezal
no flags Details
File: limits (1.29 KB, text/plain)
2013-05-16 04:28 EDT, Tomas Dolezal
no flags Details
File: maps (100.99 KB, text/plain)
2013-05-16 04:28 EDT, Tomas Dolezal
no flags Details
File: open_fds (4.55 KB, text/plain)
2013-05-16 04:28 EDT, Tomas Dolezal
no flags Details
File: proc_pid_status (945 bytes, text/plain)
2013-05-16 04:28 EDT, Tomas Dolezal
no flags Details
File: var_log_messages (13.48 KB, text/plain)
2013-05-16 04:28 EDT, Tomas Dolezal
no flags Details

  None (edit)
Description Tomas Dolezal 2013-05-16 04:27:50 EDT
Description of problem:
executed in gnome-terminal
#systemctl restart NetworkManager

Version-Release number of selected component:
cinnamon-1.8.2-4.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        cinnamon --replace
crash_function: object_instance_finalize
executable:     /usr/bin/cinnamon
kernel:         3.9.0-301.fc19.x86_64
runlevel:       N 5
uid:            19436

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 object_instance_finalize at gi/object.c:1360
 #3 finalize at jsobjinlines.h:137
 #4 FinalizeArenaList<JSObject> at jsgc.cpp:1944
 #5 JSCompartment::finalizeObjectArenaLists at jsgc.cpp:2005
 #6 MarkAndSweep at jsgc.cpp:2471
 #7 GCUntilDone at jsgc.cpp:2755
 #8 js_GC at jsgc.cpp:2824
 #9 gjs_context_gc at gjs/context.c:884
 #10 run_leisure_functions at cinnamon-global.c:1776
 #15 meta_run at core/main.c:570
Comment 1 Tomas Dolezal 2013-05-16 04:27:53 EDT
Created attachment 748650 [details]
File: backtrace
Comment 2 Tomas Dolezal 2013-05-16 04:27:57 EDT
Created attachment 748651 [details]
File: cgroup
Comment 3 Tomas Dolezal 2013-05-16 04:28:03 EDT
Created attachment 748652 [details]
File: core_backtrace
Comment 4 Tomas Dolezal 2013-05-16 04:28:16 EDT
Created attachment 748653 [details]
File: dso_list
Comment 5 Tomas Dolezal 2013-05-16 04:28:20 EDT
Created attachment 748654 [details]
File: environ
Comment 6 Tomas Dolezal 2013-05-16 04:28:25 EDT
Created attachment 748655 [details]
File: limits
Comment 7 Tomas Dolezal 2013-05-16 04:28:27 EDT
Created attachment 748656 [details]
File: maps
Comment 8 Tomas Dolezal 2013-05-16 04:28:33 EDT
Created attachment 748657 [details]
File: open_fds
Comment 9 Tomas Dolezal 2013-05-16 04:28:38 EDT
Created attachment 748658 [details]
File: proc_pid_status
Comment 10 Tomas Dolezal 2013-05-16 04:28:41 EDT
Created attachment 748659 [details]
File: var_log_messages
Comment 11 Kai Engert (:kaie) 2013-05-29 14:50:48 EDT
the vpn disconnected. then cinnamon crashed.

reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        cinnamon --replace
crash_function: object_instance_finalize
executable:     /usr/bin/cinnamon
kernel:         3.9.4-300.fc19.x86_64
package:        cinnamon-1.8.3-1.fc19
reason:         Process /usr/bin/cinnamon was killed by signal 5 (SIGTRAP)
runlevel:       N 5
uid:            1000
Comment 12 oliver 2013-06-20 09:39:42 EDT
I think it's connected to the display of a notification in the top right corner of the screen.  I am getting this several times a day now, thankfully all windows are automatically restarted...
Comment 13 Julian Stecklina 2013-06-21 15:46:33 EDT
I got this right after resume.
Comment 14 Lukas Marek 2013-06-22 17:45:21 EDT
I'm getting this every time I connect to a wifi and then disable it using networ-manager applet.

cinnamon-1.9.1-12.fc19.x86_64
Comment 15 Antoine Martin 2013-06-25 23:14:11 EDT
Same as Lukas: happens reliably if I disconnect from the wifi using nm (or rather, disconnect from whatever connection was running when I first logged in?)
Comment 16 Fabien Archambault 2013-07-01 04:58:20 EDT
Same here, after a NM disconnect of wireless
Comment 17 Lukas Marek 2013-07-01 08:44:38 EDT
Probably related: http://github.com/linuxmint/Cinnamon/issues/2125
Comment 18 Antoine Martin 2013-07-01 08:52:45 EDT
What makes this bug much worse than it sounds is that half the time I get the screen saying "oh no" covering all of my display(s) then I have to find a way to kill that to be able to say yes to "restart cinnamon", or I lose what I was doing.


Feel free to skip this rant:
who came up with this "oh no" screen anyway? How does it help anyone? It hides the real cause (not to be found in xsession-errors, or anywhere that I could find) and it only offers a single choice: "OK", and in fact it is anything but OK at this point: it will kill the X11 server and tear down all your applications! Terrible, terrible UI and choice of action.
I've seen this "oh no" screen far too many times, and to me it usually means: install a DE environment that works, this one won't and won't tell you why either.
Comment 19 Kai Engert (:kaie) 2013-07-01 09:02:03 EDT
(In reply to Antoine Martin from comment #18)
> What makes this bug much worse than it sounds is that half the time I get
> the screen saying "oh no" covering all of my display(s) then I have to find
> a way to kill that to be able to say yes to "restart cinnamon", or I lose
> what I was doing.

Indeed. Very annoying. There should be an easy way to kill the forced-foreground oh-no-forced-logoug dialog, if one is certain that continuing is acceptable and life-saving.
Comment 20 Iftikhar Rathore 2013-07-05 23:13:42 EDT
It is the same for me on a "MacBook Pro" with ATI Radeon and on a Lenovo W530 with NVidia Quatro. It happens with or without proprietary drivers. One othe thing to mention is that they were both upgraded from FC-18.

This issue only happens with VPN notification, othet notification even from NM (wireless connected, disconnected) do not cause the crash. A new version of NetworkManager was just pushed and it did not make any difference, it is till crashing.
Comment 21 David Timms 2013-07-06 23:43:29 EDT
recent changes:
-  upgrade fedora 18 to fedora 19 via fedup (iso only, now doingremaining updates).
- new mouse: usb logitech g600 with 12 shortcut buttons on side. These are by default set for digits.
Notice that sometimes I accidently press one of the side buttons. usually a digital it types into firefox or terminal. But sometimes, the mouse cursor disappears. If the location that the mouse is over has some visual feeback, then as you move the mouse, oyou can sort of work out where the pointer currently is.
This can be resolved by switch user, loggin in as another user, logout, ssitch back to original user.

Updates may have been running/installing while this crash occured.

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        cinnamon --replace
crash_function: object_instance_finalize
executable:     /usr/bin/cinnamon
kernel:         3.9.5-301.fc19.x86_64
package:        cinnamon-1.9.1-12.fc19
reason:         Process /usr/bin/cinnamon was killed by signal 5 (SIGTRAP)
runlevel:       N 5
uid:            1000
xsession_errors: Window manager warning: Log level 16: cinnamon: Fatal IO error 0 (Success) on X server :0.
Comment 22 Anand Subramanian 2013-07-10 14:27:35 EDT
I see this with Fedora 19:
cinnamon.x86_64                        1.9.1-12.fc19 

There is a consistent crash every time I disconnect my VPN (vpnc). It throws up a cinnamon crash error and I need to logout and login again, my entire state wiped out...
VPN connect using vpnc proceeds smoothly (though that seems to have a different issue of not managing to save the Group password consistently) but disconnect always crashes cinnamon.
Comment 23 PJ Waskiewicz 2013-07-11 04:01:58 EDT
Any update from the devs on this?  Between this bug and the inability to shut down a VM without a host panic, Fedora 19 is very difficult to use on a daily basis.  Any updates would be much appreciated.
Comment 24 Joshua Entwistle 2013-07-11 07:25:52 EDT
I'm not sure exactly what caused the crash.

I was reconfiguring some port settings on my router, which caused a momentary WiFi drop out.  Whilse trying to get Cinnamon to refresh the networks in the area, I accidetally RMB on another network...  boom.

I have no idea if this can be reproduced - or even if this is what caused the drop.

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        cinnamon --replace
crash_function: object_instance_finalize
executable:     /usr/bin/cinnamon
kernel:         3.9.5-301.fc19.x86_64
package:        cinnamon-1.9.1-12.fc19
reason:         Process /usr/bin/cinnamon was killed by signal 5 (SIGTRAP)
runlevel:       N 5
uid:            1000
Comment 25 Julian Stecklina 2013-07-12 04:55:00 EDT
This is rather easy to trigger by either toggling Wifi on/off or a suspend/resume cycle. Very annoying. :(
Comment 26 Anand Subramanian 2013-07-12 07:11:00 EDT
It is very easily seen on Fedora19. As reported several times, earlier in this thread, its very easily triggered by wi-fi or VPN (ON/OFF button) - at least for me. I did try to do yum update to move to Fedora 19-GA to check if it resolved the issue. Unfortunately that did not help. So finally moved to Mate, to finally breathe again :-) Not sure if this is related, but some of my colleagues don't seem to hit the issue after yum update on Fedora19 and/or Fedora19-GA but the difference between their cases and mine is that I am on Lenovo X230 while their model happens to be X220. Thanks!
Comment 27 leigh scott 2013-07-12 08:09:44 EDT
I believe I've located the cause of the issue, please test

https://koji.fedoraproject.org/koji/buildinfo?buildID=433011

and report here if it fixes the issue.
Comment 28 Lukas Marek 2013-07-12 08:33:08 EDT
The fix works for me.

Thanks Leigh.
Comment 29 Fedora Update System 2013-07-12 09:01:14 EDT
cinnamon-1.9.1-16.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cinnamon-1.9.1-16.fc19
Comment 30 Fedora Update System 2013-07-12 21:50:12 EDT
Package cinnamon-1.9.1-16.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cinnamon-1.9.1-16.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12882/cinnamon-1.9.1-16.fc19
then log in and leave karma (feedback).
Comment 31 Fedora Update System 2013-07-13 23:31:59 EDT
cinnamon-1.9.1-16.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.