Bug 963605 - new folders are created when you change the language
new folders are created when you change the language
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xdg-user-dirs-gtk (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 04:32 EDT by anish
Modified: 2015-04-12 19:12 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-17 09:52:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the problem (48.67 KB, image/png)
2013-05-16 04:32 EDT, anish
no flags Details

  None (edit)
Description anish 2013-05-16 04:32:59 EDT
Created attachment 748661 [details]
screenshot of the problem

Description of problem:
I have installed F19 with Marathi language and after login i changed language to English and then i log off and then login into system again.
At the time of login, a pop comes with message "do you wan't to keep old names or new names of the system folder".
I chose the option "new names" i.e English names
After this step, all the name of system folders(Desktop,...) had changed except Pictures,a new folder named Pictures has created instead of renaming the old folder "छायाचित्र" (which is a pictures in English")

Please not that i had stored few pictures in that folder.
I am attaching screen shot for the bug.


How reproducible:


Steps to Reproduce:
1. Install F19 with Marathi language
2. Change the language to English 
3. After login with new language a pop box comes up
4: Choose new language settings

  
Actual results:
 
Name of system folders(Desktop,...) had changed except folder Pictures,a new folder named Pictures has created instead of renaming the old folder "छायाचित्र" (which is a pictures in English")


Expected results:
New folder should not get created 

Additional info:
Comment 1 Pravin Satpute 2013-05-16 08:11:21 EDT
Me too able to reproduce this problem.

I feel basically problem happens, when there is some content in your existing folder.

Example:

/home/user/Downloads folder has some content
/home/user/Pictures folder is empty

In above case, when i am changing locale from en to mr, it is properly converting 

1. Pictures folder name to Marathi locale name.
2. But it is keeping Downloads folder and creating one new folder with localized name of Download.  (Bug)
Comment 2 Matthias Clasen 2013-05-17 09:46:21 EDT
This is intentional, afair - it was deemed too risky to move existing content, so we just create new folders.
Comment 3 Matthias Clasen 2013-05-17 09:52:25 EDT
Alex confirms my memory: Given that this is a very rare situation, and moving the content has risks, we decided not to do it.

We could perhaps do better wrt. explaining the situation in the dialog.

I'll close this bug for now, since I don't envision me or Alex to work on it.
Comment 4 Pravin Satpute 2013-05-20 03:59:35 EDT
Yes, considering this risk me too agree with this.

Thanks !!

Note You need to log in before you can comment on or make changes to this bug.