Bug 963641 - SELinux is preventing /usr/bin/clamscan from 'getattr' accesses on the chr_file /dev/cpu/5/msr.
SELinux is preventing /usr/bin/clamscan from 'getattr' accesses on the chr_fi...
Status: CLOSED DUPLICATE of bug 963639
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:0d67e4171f09ee02b9e1eb1c76f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 06:07 EDT by Grosswiler Roger
Modified: 2013-05-16 06:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-16 06:33:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Grosswiler Roger 2013-05-16 06:07:55 EDT
Description of problem:
SELinux is preventing /usr/bin/clamscan from 'getattr' accesses on the chr_file /dev/cpu/5/msr.

*****  Plugin catchall (100. confidence) suggests  ***************************

If sie denken, dass es clamscan standardmässig erlaubt sein sollte, getattr Zugriff auf msr chr_file zu erhalten.
Then sie sollten dies als Fehler melden.
Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
Do
zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
# grep clamscan /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:antivirus_t:s0-s0:c0.c1023
Target Context                system_u:object_r:cpu_device_t:s0
Target Objects                /dev/cpu/5/msr [ chr_file ]
Source                        clamscan
Source Path                   /usr/bin/clamscan
Port                          <Unbekannt>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-42.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.1-301.fc19.x86_64 #1 SMP Wed
                              May 8 18:02:34 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-05-15 06:55:08 CEST
Last Seen                     2013-05-16 06:35:26 CEST
Local ID                      413ab843-954c-4bb0-9934-99904e4bf49a

Raw Audit Messages
type=AVC msg=audit(1368678926.714:45784): avc:  denied  { getattr } for  pid=22435 comm="clamscan" path="/dev/cpu/5/msr" dev="devtmpfs" ino=1118 scontext=system_u:system_r:antivirus_t:s0-s0:c0.c1023 tcontext=system_u:object_r:cpu_device_t:s0 tclass=chr_file


Hash: clamscan,antivirus_t,cpu_device_t,chr_file,getattr

audit2allow

#============= antivirus_t ==============
allow antivirus_t cpu_device_t:chr_file getattr;

audit2allow -R
require {
	type antivirus_t;
	type cpu_device_t;
	class chr_file getattr;
}

#============= antivirus_t ==============
allow antivirus_t cpu_device_t:chr_file getattr;


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.1-301.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-05-16 06:33:54 EDT

*** This bug has been marked as a duplicate of bug 963639 ***

Note You need to log in before you can comment on or make changes to this bug.