Bug 963649 - Flipping bits manually doesn't work if not fixed number format
Flipping bits manually doesn't work if not fixed number format
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-calculator (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: beta
: 7.0
Assigned To: Alexander Larsson
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 06:24 EDT by Martin Simon
Modified: 2016-09-19 22:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-08 16:42:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Simon 2013-05-16 06:24:15 EDT
Description of problem:
When number is displayed in scientific notation, the manual bit flipping (clicking on the bit array under the display area in the Programming mode) is not working. It's most probably a bug in the parser.

Version-Release number of selected component (if applicable):
gnome-calculator-3.8.1-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Start gnome-calculator, switch to the programming mode
2. Make sure number format is not set to fixed
3. Click on the most significant bit under the display area
  
Actual results:
The correct number is displayed in scientific notation (e.g 9.223372037×10¹⁸), but the bits are now gray and are no longer working

Expected results:
Correct number displayed as it is and be able to continue flipping bits

Additional info:
Comment 1 Martin Simon 2014-02-27 05:32:48 EST
this bug is still present in gnome-calculator-3.8.2-4.el7.x86_64

*** This bug has been marked as a duplicate of bug 1070259 ***
Comment 2 Martin Simon 2014-02-27 05:34:14 EST
Sorry, wrong bug. This is not a duplicate, this bug is still present in latest version of gnome-calculator
Comment 3 RHEL Product and Program Management 2014-03-22 02:51:24 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Vitezslav Humpa 2015-05-07 06:05:38 EDT
This bug is fixed within the GNOME 3.14 codebase (gnome-calculator-3.14.1-1.el7.x86_64).
Comment 7 Martin Simon 2015-09-02 06:20:16 EDT
Despite the comment 5, I'm still able to reproduce this bug. The reproducer and actual behavior is the same as in comment 0. Tested in gnome-calculator-3.14.1-2.el7.x86_64
Comment 8 Matthias Clasen 2015-09-08 16:42:46 EDT
IT is unlikely that we will get a fix for this unless it appeared upstream first, and we rebase to a newer version.

Note You need to log in before you can comment on or make changes to this bug.