Bug 963663 - Integrated Mobile Broadband Ericsson H5321gw wwan0 broken (DHCPv4 request timed out)
Integrated Mobile Broadband Ericsson H5321gw wwan0 broken (DHCPv4 request tim...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 06:43 EDT by Japplo
Modified: 2014-01-06 08:36 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-06 08:36:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (78.85 KB, text/plain)
2013-05-16 06:45 EDT, Japplo
no flags Details
nm debug (7.84 KB, text/plain)
2013-05-16 06:46 EDT, Japplo
no flags Details
journalctl (145.69 KB, text/plain)
2013-05-16 07:09 EDT, Japplo
no flags Details

  None (edit)
Description Japplo 2013-05-16 06:43:22 EDT
Description of problem:
Mobile broadband modem does not connect with kernel >= 3.8.
Networkmanager debug shows "DHCPv4 request timed out"

Version-Release number of selected component (if applicable):
kernel-3.9.2-200.fc18.x86_64
kernel-headers-3.9.2-200.fc18.x86_64
kernel-modules-extra-3.9.2-200.fc18.x86_64

How reproducible:
All the time with Fedora 18 + 19

Steps to Reproduce:
1. Boot with kernel >= 3.8
2. Attempt to connect to mobile broadband

  
Actual results:
Mobile broadband modem does not connect

Expected results:
Mobile broadband modem should connect

Additional info:
Hardware:
Thinkpad X230
# lsusb
Bus 003 Device 003: ID 0bdb:1926 Ericsson Business Mobile Networks BV
Comment 1 Japplo 2013-05-16 06:45:11 EDT
Created attachment 748737 [details]
dmesg
Comment 2 Japplo 2013-05-16 06:46:28 EDT
Created attachment 748738 [details]
nm debug
Comment 3 Japplo 2013-05-16 07:09:36 EDT
Created attachment 748755 [details]
journalctl
Comment 4 Dave Jones 2013-05-16 10:29:54 EDT
there are only two patches to the mbim driver between 3.8 and 3.9
One looks like a cleanup, and the other is this..

commit 1e8bbe6cd02fc300c88bd48244ce61ad9c7d1776
Author: Bjørn Mork <bjorn@mork.no>
Date:   Thu Mar 14 01:05:13 2013 +0000

    net: cdc_ncm, cdc_mbim: allow user to prefer NCM for backwards compatibility
    
    commit bd329e1 ("net: cdc_ncm: do not bind to NCM compatible MBIM devices")
    introduced a new policy, preferring MBIM for dual NCM/MBIM functions if
    the cdc_mbim driver was enabled.  This caused a regression for users
    wanting to use NCM.
    
    Devices implementing NCM backwards compatibility according to section
    3.2 of the MBIM v1.0 specification allow either NCM or MBIM on a single
    USB function, using different altsettings.  The cdc_ncm and cdc_mbim
    drivers will both probe such functions, and must agree on a common
    policy for selecting either MBIM or NCM.  Until now, this policy has
    been set at build time based on CONFIG_USB_NET_CDC_MBIM.
    
    Use a module parameter to set the system policy at runtime, allowing the
    user to prefer NCM on systems with the cdc_mbim driver.



Can you try that module parameter ? 'prefer_mbim'
Comment 5 Japplo 2013-05-16 11:01:56 EDT
hi dave, the problem exist since kernel 3.8. It should be something between 3.7.9 - 3.8.x
Comment 6 Japplo 2013-05-16 11:15:51 EDT
I tried echo "options cdc_ncm prefer_mbim=Y" > /etc/modprobe.d/cdc_ncm.conf but the problem still exist
Comment 7 Japplo 2013-05-16 11:48:12 EDT
argh echo "options cdc_ncm prefer_mbim=N" > /etc/modprobe.d/cdc_ncm.conf and the Mobile broadband modem works, thanks dave
Comment 8 Dan Williams 2013-05-16 15:06:16 EDT
The reason things fail is that ModemManager in Fedora <= 19 doesn't have the bits to handle MBIM yet, that's only landing in F20.  And when the Ericsson device is driven by MBIM but set up by AT commands (as is the case when you don't have native MBIM support in userspace) then the eth port simply won't work.

The 5321 is capable of using MBIM or NCM, but we shouldn't have userspace programs trying to unbind one driver and rebind the other based on what they support.  We have two options:

1) blacklist the 5321 (and maybe other dual NCM/MBIM devices) from the MBIM driver until userspace catches up and then revert this

2) make userspace catch up

We aren't shipping ModemManager 0.8 (which can do MBIM) in Fedora 19 because it's an API break and KDE hasn't caught up yet.  What we should probably do for Fedora < 20 is a modprobe option that forces a preference for NCM instead of MBIM, and anyone who really wants to use MBIM can remove that.
Comment 9 Dave Jones 2013-05-16 15:20:36 EDT
Dan, I'll merge this patch from debian that reverts the 'do mbim by default' part.

http://anonscm.debian.org/viewvc/kernel/dists/trunk/linux/debian/patches/debian/cdc_ncm-cdc_mbim-use-ncm-by-default.patch?revision=19955&view=markup

sound good ?
Comment 10 mrmx1@live.com 2013-09-22 17:40:51 EDT
Had the same problem with a DW5560.
Workaround echo "options cdc_ncm prefer_mbim=N" > /etc/modprobe.d/cdc_ncm.conf did work for me too.
Comment 11 Josh Boyer 2013-09-23 10:37:01 EDT
Dan, see comment #9.  Is userspace in all of Fedora now ready for MBIM, or should we carry the patch Dave pointed to?
Comment 12 mrmx1@live.com 2013-09-23 14:05:29 EDT
(In reply to mrmx1@live.com from comment #10)
> Had the same problem with a DW5560.
> Workaround echo "options cdc_ncm prefer_mbim=N" >
> /etc/modprobe.d/cdc_ncm.conf did work for me too.

Sorry, forgot to add config info
Fedora 18 i386
kernel-PAE-3.10.11-100.fc18.i686
NetworkManager-0.9.8.2-1.fc18.i686
ModemManager-0.6.2.0-1.fc18.i686.rpm
Comment 13 Justin M. Forbes 2013-10-18 17:18:15 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 18 kernel bugs.

Fedora 18 has now been rebased to 3.11.4-101.fc18.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 19, and are still experiencing this issue, please change the version to Fedora 19.

If you experience different issues, please open a new bug report for those.
Comment 14 Daniel 2013-11-21 11:48:50 EST
Hi All,

I have F19 64-bit with Lenovo x230 with same H5321gw and I am experiencing exactly the same problems. It sends dhcp requests but not able to make connection. I have tried the above fixed but still no joy...:)

Is there a known fix for this same problem for F19 64-bit?
Comment 15 Fedora End Of Life 2013-12-21 08:34:04 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 16 mrmx1@live.com 2013-12-25 17:19:11 EST
Retested after upgrade to FC20.
Removed /etc/modprobe.d/cdc_ncm.conf, which was the workaround for FC18, and now my DW5560 WWAN card is able to connect.

Fedora 20 i386
kernel-PAE-3.12.5-302.fc20.i686
NetworkManager-0.9.9.0-22.git20131003.fc20.i686
ModemManager-1.1.0-2.git20130913.fc20.i686
Comment 17 Josh Boyer 2014-01-06 08:36:47 EST
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.