Bug 963671 - tar: option '--xattr' is ambiguous
tar: option '--xattr' is ambiguous
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tar (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Pavel Raiskup
qe-baseos-daemons
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 07:07 EDT by Petr Sklenar
Modified: 2013-06-07 03:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 03:03:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2013-05-16 07:07:12 EDT
Description of problem:
option '--xattr' is not working

Version-Release number of selected component (if applicable):
tar-1.26-21.el7

How reproducible:
always

Steps to Reproduce:
1. cd /;tar cvf name.tar /tmp/
2. tar --xattr -xf name.tar
  
Actual results:
tar is not untar
tar: option '--xattr' is ambiguous
Try `tar --help' or `tar --usage' for more information.

Expected results:
tar is untar

Additional info:
tar-1.26-12.el7.x86_64: works
tar-1.26-21.el7.ppc64: this bug
Comment 4 Pavel Raiskup 2013-05-16 07:24:28 EDT
Well.  In newest tar are new options --xattrs-include/--xattrs-exclude, which
clashes with --xattrs in that way.  These options were not in RHEL6.

I'm not sure if the --xattr option was ever supported in RHEL - most probably
not.  The bug #963671 seems to be just about memory leak, it is not testing
whether the '--xattr' works.  I would simply fix that test.

Pavel
Comment 5 Pavel Raiskup 2013-05-16 07:56:05 EDT
> not.  The bug #963671 seems to be just about memory leak, it is not testing

Ohh .. I mean the bug #518079 of course.

----

The xattrs-include/xattrs-exclude was added upstream by this commit:

http://git.savannah.gnu.org/cgit/tar.git/commit/?id=696338043e52f44

Pavel
Comment 6 Pavel Raiskup 2013-06-07 03:03:40 EDT
With Petr's ACK: this is expected behavior and unlikely to be changed (--xattr
option was never really supported) - so not a bug in RHEL7 tar and our tests
will be changed.  Thanks for looking at it!  Pavel

Note You need to log in before you can comment on or make changes to this bug.