Bug 963678 - add discard support (FALLOC_FL_PUNCH_HOLE)
add discard support (FALLOC_FL_PUNCH_HOLE)
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: fuse (Show other bugs)
mainline
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Brian Foster
:
Depends On: 949242
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 07:25 EDT by Brian Foster
Modified: 2014-04-17 07:42 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 07:42:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Foster 2013-05-16 07:25:38 EDT
Add support for gluster discard (punch hole, via fallocate()). Expose via fuse and gfapi.
Comment 1 Anand Avati 2013-05-24 14:05:03 EDT
REVIEW: http://review.gluster.org/5090 (glusterfs: discard (hole punch) support) posted (#1) for review on master by Brian Foster (bfoster@redhat.com)
Comment 2 Brian Foster 2013-05-24 14:14:36 EDT
http://review.gluster.org/5090
Comment 3 Anand Avati 2013-06-04 11:52:20 EDT
REVIEW: http://review.gluster.org/5090 (glusterfs: discard (hole punch) support) posted (#2) for review on master by Brian Foster (bfoster@redhat.com)
Comment 4 Anand Avati 2013-06-04 11:52:42 EDT
REVIEW: http://review.gluster.org/5144 (gfapi: async discard support) posted (#1) for review on master by Brian Foster (bfoster@redhat.com)
Comment 5 Anand Avati 2013-06-04 23:40:25 EDT
REVIEW: http://review.gluster.org/5146 (just a test Signed-off-by: jian.hou <hjimmy19870806@gmail.com>) posted (#1) for review on release-3.4 by 健 侯 (hjimmy19870806@gmail.com)
Comment 6 Anand Avati 2013-06-11 09:01:46 EDT
REVIEW: http://review.gluster.org/5144 (gfapi: async discard support) posted (#2) for review on master by Brian Foster (bfoster@redhat.com)
Comment 7 Anand Avati 2013-06-11 09:02:35 EDT
REVIEW: http://review.gluster.org/5090 (glusterfs: discard (hole punch) support) posted (#3) for review on master by Brian Foster (bfoster@redhat.com)
Comment 8 Anand Avati 2013-06-13 17:38:30 EDT
COMMIT: http://review.gluster.org/5090 committed in master by Anand Avati (avati@redhat.com) 
------
commit 17f287172413dc04244781aa5302a0e4f10e2777
Author: Brian Foster <bfoster@redhat.com>
Date:   Thu May 23 12:19:42 2013 -0400

    glusterfs: discard (hole punch) support
    
    Add support for the DISCARD file operation. Discard punches a hole
    in a file in the provided range. Block de-allocation is implemented
    via fallocate() (as requested via fuse and passed on to the brick
    fs) but a separate fop is created within gluster to emphasize the
    fact that discard changes file data (the discarded region is
    replaced with zeroes) and must invalidate caches where appropriate.
    
    BUG: 963678
    Change-Id: I34633a0bfff2187afeab4292a15f3cc9adf261af
    Signed-off-by: Brian Foster <bfoster@redhat.com>
    Reviewed-on: http://review.gluster.org/5090
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 9 Anand Avati 2013-06-13 17:39:30 EDT
COMMIT: http://review.gluster.org/5144 committed in master by Anand Avati (avati@redhat.com) 
------
commit cede8eb3d0007dcd6eb8929d5031ff25be955ed6
Author: Brian Foster <bfoster@redhat.com>
Date:   Tue Jun 4 11:54:43 2013 -0400

    gfapi: async discard support
    
    From: Bharata B Rao <bharata@linux.vnet.ibm.com>
    
    Add glfs_discard_async() to meet QEMU's discard requirements.
    
    BUG: 963678
    Change-Id: I97723107fca88dd96cddc08cd67a286645a37922
    Signed-off-by: Bharata B Rao <bharata@linux.vnet.ibm.com>
    Signed-off-by: Brian Foster <bfoster@redhat.com>
    Reviewed-on: http://review.gluster.org/5144
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 10 Niels de Vos 2014-04-17 07:42:25 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.