Bug 963695 - JBOSS ON doesn't discover JBoss As 7 (JBOSS EAP 6) 's JVM as child resource
JBOSS ON doesn't discover JBoss As 7 (JBOSS EAP 6) 's JVM as child resource
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.1.2
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 08:11 EDT by poonamkamboj
Modified: 2013-05-24 03:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 03:59:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description poonamkamboj 2013-05-16 08:11:45 EDT
Description of problem:
When JBOSS AS & is started as part of JBOSS EAP on remote machine , JBOSS ON inventory does not discover the JBOSS AS 7 JVM. 

Version-Release number of selected component (if applicable):
JBOSS EAP 6.0.1 (JBOSS AS 7)
JAVA 1.7 on both machines.
JON 3.1.2 
both JBOSS EAP and JON machines are RHEL 6.
jon-plugin-pack-eap-3.1.2.GA.zip
Agent : rhq-enterprise-agent-4.4.0.JON312GA.jar

How reproducible:
Start JBOSS AS 7 standalone-full.xml as part of JBOSS EAP 6
Start the agent on this machine.
even tried discovery -f.

Steps to Reproduce:
1. Start JBOSS 7  having JAVA_OPTS = "$JAVA_OPTS -Djboss.platform.mbeanserver" in standalone.conf. I can see in the console logs that same JAVA_OPTS is available while starting JBOSS AS 7
2. Start JON Server and Agent on both machines
3. tried discovery -f
  
Actual results:
JON discovers EAP and shows its availability in inventory. But doesn't show the JBOSS AS JVM , Where as for the Agent it shows that JVM 1.7 is available.


Expected results:
JON should discover the JBOSS AS 7's JVM as well.

Additional info:
Please let me know if additional info required
Comment 1 poonamkamboj 2013-05-24 03:59:06 EDT
JVM properties appeat as platform-mbean child resource to JBOSS EAP 6 (AS 7) when we set JAVA_OPTS = "$JAVA_OPTS -Djboss.platform.mbeanserver"

I was searching for JVM or JMX as child resource.

Please update the JON documentation as well as its misleading information.

Note You need to log in before you can comment on or make changes to this bug.