Bug 963696 - [abrt] xsane-0.998-12.fc17: preview_display_valid: Process /usr/bin/xsane was killed by signal 11 (SIGSEGV)
[abrt] xsane-0.998-12.fc17: preview_display_valid: Process /usr/bin/xsane was...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xsane (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
abrt_hash:95c23cd350c205dd20415f22ef4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 08:14 EDT by gala_dragos
Modified: 2013-05-27 22:17 EDT (History)
1 user (show)

See Also:
Fixed In Version: xsane-0.998-21.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-27 21:01:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (39.97 KB, text/plain)
2013-05-16 08:14 EDT, gala_dragos
no flags Details
File: cgroup (129 bytes, text/plain)
2013-05-16 08:14 EDT, gala_dragos
no flags Details
File: core_backtrace (4.36 KB, text/plain)
2013-05-16 08:14 EDT, gala_dragos
no flags Details
File: dso_list (13.96 KB, text/plain)
2013-05-16 08:15 EDT, gala_dragos
no flags Details
File: environ (1.23 KB, text/plain)
2013-05-16 08:15 EDT, gala_dragos
no flags Details
File: limits (1.29 KB, text/plain)
2013-05-16 08:15 EDT, gala_dragos
no flags Details
File: maps (40.84 KB, text/plain)
2013-05-16 08:15 EDT, gala_dragos
no flags Details
File: open_fds (503 bytes, text/plain)
2013-05-16 08:16 EDT, gala_dragos
no flags Details
File: proc_pid_status (791 bytes, text/plain)
2013-05-16 08:16 EDT, gala_dragos
no flags Details
File: smolt_data (2.61 KB, text/plain)
2013-05-16 08:16 EDT, gala_dragos
no flags Details
File: var_log_messages (517 bytes, text/plain)
2013-05-16 08:16 EDT, gala_dragos
no flags Details

  None (edit)
Description gala_dragos 2013-05-16 08:14:01 EDT
Description of problem:
testing a gt68xx scanner

Version-Release number of selected component:
xsane-0.998-12.fc17

Additional info:
backtrace_rating: 4
cmdline:        xsane
crash_function: preview_display_valid
executable:     /usr/bin/xsane
kernel:         3.8.11-100.fc17.i686.PAE
uid:            1000
ureports_counter: 1
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 preview_display_valid at ../../src/xsane-preview.c:7561
 #1 xsane_update_param at ../../src/xsane-front-gtk.c:1731
 #2 preview_establish_selection at ../../src/xsane-preview.c:755
 #3 preview_update_surface at ../../src/xsane-preview.c:4883
 #4 preview_scan_done at ../../src/xsane-preview.c:1871
 #5 preview_destroy at ../../src/xsane-preview.c:5227
 #6 xsane_quit at ../../src/xsane.c:2370
 #7 xsane_scan_win_delete at ../../src/xsane.c:2519
 #8 _gtk_marshal_BOOLEAN__BOXED at gtkmarshalers.c:86
 #13 gtk_widget_event_internal at gtkwidget.c:5017
Comment 1 gala_dragos 2013-05-16 08:14:36 EDT
Created attachment 748768 [details]
File: backtrace
Comment 2 gala_dragos 2013-05-16 08:14:50 EDT
Created attachment 748769 [details]
File: cgroup
Comment 3 gala_dragos 2013-05-16 08:14:59 EDT
Created attachment 748770 [details]
File: core_backtrace
Comment 4 gala_dragos 2013-05-16 08:15:11 EDT
Created attachment 748771 [details]
File: dso_list
Comment 5 gala_dragos 2013-05-16 08:15:23 EDT
Created attachment 748772 [details]
File: environ
Comment 6 gala_dragos 2013-05-16 08:15:34 EDT
Created attachment 748773 [details]
File: limits
Comment 7 gala_dragos 2013-05-16 08:15:48 EDT
Created attachment 748774 [details]
File: maps
Comment 8 gala_dragos 2013-05-16 08:16:00 EDT
Created attachment 748775 [details]
File: open_fds
Comment 9 gala_dragos 2013-05-16 08:16:10 EDT
Created attachment 748780 [details]
File: proc_pid_status
Comment 10 gala_dragos 2013-05-16 08:16:21 EDT
Created attachment 748784 [details]
File: smolt_data
Comment 11 gala_dragos 2013-05-16 08:16:23 EDT
Created attachment 748786 [details]
File: var_log_messages
Comment 12 Nils Philippsen 2013-05-17 07:50:04 EDT
It looks as if while trying to destroy the preview object when quitting xsane, it tries to use it despite it being set to NULL already. Can you reproduce this issue reliably?
Comment 13 gala_dragos 2013-05-17 09:27:14 EDT
Just to add to how it happened:

- minimized preview window after clicking "acquire preview";
- allowed some time to acquire, but not enough to actually acquire the whole preview;
- restored preview window, it was all blank (no buttons, no text, no image);
- because I could not restore the preview window properly I've closed it;
- reopened a new preview window, but it was still blank;
- closed xsane, it crashed.

I no longer have the scanner attached, but it happened also on Fedora 16, and on another PC with Fedora 17. Scanner was the same.
Comment 14 Fedora Update System 2013-05-17 11:52:27 EDT
xsane-0.998-21.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xsane-0.998-21.fc18
Comment 15 Fedora Update System 2013-05-17 11:52:35 EDT
xsane-0.998-21.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xsane-0.998-21.fc17
Comment 16 Fedora Update System 2013-05-17 11:52:43 EDT
xsane-0.998-21.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xsane-0.998-21.fc19
Comment 17 Fedora Update System 2013-05-17 18:18:35 EDT
Package xsane-0.998-21.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xsane-0.998-21.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8453/xsane-0.998-21.fc19
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2013-05-27 21:01:40 EDT
xsane-0.998-21.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2013-05-27 21:02:29 EDT
xsane-0.998-21.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2013-05-27 22:17:07 EDT
xsane-0.998-21.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.