Bug 963703 - nrpe.cfg set config values after including user configuration(s)
Summary: nrpe.cfg set config values after including user configuration(s)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nrpe
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-16 12:25 UTC by Maarten Kossen
Modified: 2017-07-05 17:12 UTC (History)
4 users (show)

Fixed In Version: nrpe-2.14-5.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-10-27 05:29:09 UTC
Type: Bug


Attachments (Terms of Use)

Description Maarten Kossen 2013-05-16 12:25:33 UTC
Description of problem:
In /etc/nagios/nrpe.cfg the includedir config option is not the last config option in the file, resulting in any config options below the includedir one to override anything that may have been included.

Version-Release number of selected component (if applicable):
2.13

How reproducible:
You need a check that fails under the conditions set in /etc/nagios/nrpe.cfg but would be OK under the conditions set in /etc/nrpe.d/nrpe_local.cfg.

Steps to Reproduce:
1. Add a file in /etc/nrpe.d/ (for example: /etc/nrpe.d/nrpe_local.cfg) with a command definition that exists in /etc/nagios/nrpe.cfg (like check_total_procs) with a _lower_ thresholds than in /etc/nagios/nrpe.cfg
2. Make sure the check would be OK under the thresholds configuration in /etc/nrpe.d/nrpe_local.cfg but would fail under the thresholds in /etc/nagios/nrpe.cfg
3. Conclude that the checks defined in /etc/nagios/nrpe.cfg override the ones defined in /etc/nrpe.d/nrpe_local.cfg because they are defined after the includedir config option was defined.
  
Actual results:
A failing nagios check.

Expected results:
An OK nagios check.

Additional info:
None.

Comment 1 Fedora Update System 2013-10-16 15:46:57 UTC
nrpe-2.14-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/nrpe-2.14-5.fc19

Comment 2 Fedora Update System 2013-10-16 15:47:15 UTC
nrpe-2.14-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/nrpe-2.14-5.fc20

Comment 3 Fedora Update System 2013-10-16 15:47:30 UTC
nrpe-2.14-5.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/nrpe-2.14-5.el6

Comment 4 Fedora Update System 2013-10-16 15:47:48 UTC
nrpe-2.14-5.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/nrpe-2.14-5.el5

Comment 5 Fedora Update System 2013-10-17 18:03:29 UTC
Package nrpe-2.14-5.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing nrpe-2.14-5.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11848/nrpe-2.14-5.el6
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2013-10-27 05:29:09 UTC
nrpe-2.14-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2013-11-07 19:16:36 UTC
nrpe-2.14-5.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2013-11-07 19:18:44 UTC
nrpe-2.14-5.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2013-11-10 07:49:12 UTC
nrpe-2.14-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 QITS GmbH Team Linux 2017-07-05 11:13:01 UTC
(In reply to Fedora Update System from comment #9)
> nrpe-2.14-5.fc20 has been pushed to the Fedora 20 stable repository.  If
> problems still persist, please make note of it in this bug report.

Right, in NRPE 3.11, which was installed on some of my hosts since yesterday, this issue is back again. The include-statement includes stuff in /etc/nrpe.d/, then defines commands.

Not only that, but the load-check will issuse a critical at a load of 0.3.

[root@hostname ~]# rpm -qi nrpe
Name        : nrpe
Version     : 3.1.1
Release     : 1.el7
Architecture: x86_64
Install Date: Mi 05 Jul 2017 13:05:16 CEST
Group       : Applications/System
Size        : 341792
License     : GPLv2
Signature   : RSA/SHA256, Do 15 Jun 2017 03:02:22 CEST, Key ID 6a2faea2352c64e5
Source RPM  : nrpe-3.1.1-1.el7.src.rpm
Build Date  : Do 15 Jun 2017 02:50:55 CEST
Build Host  : buildvm-20.phx2.fedoraproject.org
Relocations : (not relocatable)
Packager    : Fedora Project
Vendor      : Fedora Project
URL         : http://www.nagios.org
Summary     : Host/service/network monitoring agent for Nagios
Description :
Nrpe is a system daemon that will execute various Nagios plugins
locally on behalf of a remote (monitoring) host that uses the
check_nrpe plugin.  Various plugins that can be executed by the
daemon are available at:
http://sourceforge.net/projects/nagiosplug

This package provides the core agent.

Comment 11 QITS GmbH Team Linux 2017-07-05 17:12:34 UTC
This bug cannot be reopened, so i have made a new one, sorry for the noise: https://bugzilla.redhat.com/show_bug.cgi?id=1467971


Note You need to log in before you can comment on or make changes to this bug.