Bug 963715 - Firmware loading for ds3000 fails with kernel 3.9.2
Firmware loading for ds3000 fails with kernel 3.9.2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 09:08 EDT by Michael Class
Modified: 2014-01-01 14:04 EST (History)
11 users (show)

See Also:
Fixed In Version: kernel-3.10.7-200.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-17 20:32:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Class 2013-05-16 09:08:51 EDT
Description of problem:

Using ds3000 driver for a TeVII S471 DVB Card does not load the firmware from /lib/firmware/dvb-fe-ds3000.fw in kernel 3.9.2 any more. It was working fine up to kernel 3.8.11.

Version-Release number of selected component (if applicable):
Not working: 3.9.2-200.fc18.x86_64
Working on: 3.8.11-200.fc18.x86_64

How reproducible:
Boot kernel 3.9.2 and start application using the ds3000 dvb interface (vdr in my case). 

If things do work I get something like:
May 16 14:46:14 pc-micha kernel: [  566.451026] ds3000_firmware_ondemand: Waiting for firmware upload (dvb-fe-ds3000.fw)...
May 16 14:46:14 pc-micha kernel: [  566.451071] ds3000_firmware_ondemand: Waiting for firmware upload(2)...
May 16 14:46:15 pc-micha vdr: [4343] DVB API version is 0x050A (VDR was built with 0x0509)
May 16 14:46:15 pc-micha vdr: [4343] frontend 0/0 provides DVB-S,DVB-S2 with QPSK ("Montage Technology DS3000")
May 16 14:46:15 pc-micha vdr: [4343] found 1 DVB device

For kernel 3.9.2 it only gets to "Waiting for firmware upload(2)"



Steps to Reproduce:
1.
2.
3.
  
Actual results:
No working DVB Interface

Expected results:
Working DVB interface

Additional info:

Building a 3.9.2 kernel with the following config option fixes the problem for me: 

CONFIG_FW_LOADER_USER_HELPER=y

This is a new config option for kernel 3.9. Do we need to enable this in the default kernel?
Comment 1 Josh Boyer 2013-05-16 09:22:57 EDT
Can you attach a full dmesg from a failing kernel?  If the firmware request failed, you should see something like this:

ds3000_firmware_ondemand: No firmware uploaded (timeout or file not found?)

The CONFIG_FW_LOADER_USER_HELPER option is supposedly a fallback option and shouldn't be required unless the firmware is in a non-standard path or perhaps the driver is doing something odd.
Comment 2 Michael Class 2013-05-17 01:58:34 EDT
Hello,

it seems that I was wrong with my conclusions. Even with the stock 3.9.2 kernel the firmware is loaded:
May 16 16:37:00 pc-micha kernel: [   68.280486] ds3000_firmware_ondemand: Waiting for firmware upload (dvb-fe-ds3000.fw)...
May 16 16:37:00 pc-micha kernel: [   68.280657] ds3000_firmware_ondemand: Waiting for firmware upload(2)...
May 16 16:37:01 pc-micha vdr: [2487] DVB API version is 0x050A (VDR was built with 0x0509)
May 16 16:37:01 pc-micha vdr: [2487] frontend 0/0 provides DVB-S,DVB-S2 with QPSK ("Montage Technology DS3000")
May 16 16:37:01 pc-micha vdr: [2487] found 1 DVB device

But with the 3.9.2 kernel I do get the following messages:

May 16 08:06:39 pc-micha vdr: [6636] switching to channel 2
May 16 08:06:48 pc-micha vdr: [6641] frontend 0/0 timed out while tuning to channel 2, tp 111361

Things seem to be working if I first boot a 3.8.11 kernel and run vdr. After a reboot, everything works in 3.9.2 kernel too. But after a cold start directly to 3.9.2 kernel, I do get the message above. So it looks as if something is not initialized correctly in the newer kernel. But this might be just a ds3000 driver issue. I will see, if I can find out more. 

DVB Card is a PCI-e TeVII 471
02:00.0 Multimedia video controller: Conexant Systems, Inc. CX23885 PCI Video and Audio Decoder (rev 02)
	Subsystem: Device d471:9022
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at f7800000 (64-bit, non-prefetchable) [size=2M]
	Capabilities: [40] Express Endpoint, MSI 00
	Capabilities: [80] Power Management version 2
	Capabilities: [90] Vital Product Data
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [200] Virtual Channel
	Kernel driver in use: cx23885

Cheers,
Michael
Comment 3 Martin Fahrendorf 2013-08-11 15:54:44 EDT
Hallo

I had the same problem. Even current 3.10.5 Kernel was not working. I found a patch at https://patchwork.linuxtv.org/patch/19301/ and after recompiling the kernel my TeVii S471 Card is back running.

regards
Martin
Comment 4 Josh Boyer 2013-08-15 09:02:19 EDT
Thanks for the pointer.  I'll get that patch in today.
Comment 5 Josh Boyer 2013-08-15 09:11:09 EDT
OK, patch added across the releases.  Thanks again.
Comment 6 Fedora Update System 2013-08-16 08:21:04 EDT
kernel-3.10.7-200.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.10.7-200.fc19
Comment 7 Fedora Update System 2013-08-16 08:23:18 EDT
kernel-3.10.7-100.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.10.7-100.fc18
Comment 8 Fedora Update System 2013-08-16 18:56:44 EDT
Package kernel-3.10.7-200.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.10.7-200.fc19'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14865/kernel-3.10.7-200.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-08-17 20:32:47 EDT
kernel-3.10.7-100.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-08-17 20:36:32 EDT
kernel-3.10.7-200.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 pjw0701-fedoraforum 2014-01-01 05:08:57 EST
The problem is still present in the current fedora 20 kernel. 
I tried different hardware: Aver 800, hauppauge nova2, and KWorld USB 2.00 and they all fail e.g.

 uname -a
Linux tiny.wells-local.org 3.12.5-302.fc20.i686 #1 SMP Tue Dec 17 21:01:18 UTC 2013 i686 i686 i386 GNU/Linux


dmesg:
[   13.711222] usb 1-4: New USB device found, idVendor=06e1, idProduct=a334
[   13.711291] usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[   13.711305] usb 1-4: Product: DVBT-USB2.0
[   13.711312] usb 1-4: Manufacturer: KWorld Co.,Ltd.
[   13.712869] dvb-usb: found a 'KWorld/ADSTech Instant DVB-T USB2.0' in warm state.
[   13.713149] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[   13.713503] DVB: registering new adapter (KWorld/ADSTech Instant DVB-T USB2.0)
[   13.729183] usb 1-4: DVB: registering adapter 1 frontend 0 (DiBcom 3000M-B DVB-T)...
[   13.819758] input: IR-receiver inside an USB DVB receiver as /devices/pci0000:00/0000:00:02.1/usb1/1-4/input/input6
[   13.819811] dvb-usb: schedule remote query interval to 150 msecs.
[   13.819815] dvb-usb: KWorld/ADSTech Instant DVB-T USB2.0 successfully initialized and connected.

...
...




[   95.146749] ds3000_firmware_ondemand: Waiting for firmware upload (dvb-fe-ds3000.fw)...
[   95.153433] ds3000_firmware_ondemand: Waiting for firmware upload(2)...
[  184.740063] ds3000_firmware_ondemand: Waiting for firmware upload (dvb-fe-ds3000.fw)...
[  184.740128] ds3000_firmware_ondemand: Waiting for firmware upload(2)...

----------------------

lsusb:
lsusb
Bus 001 Device 005: ID 06e1:a334 ADS Technologies, Inc. 
Bus 001 Device 002: ID 9022:d660 TeVii Technology Ltd. DVB-S2 S660
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 05af:0630 Jing-Mold Enterprise Co., Ltd 
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

(The TeVii is working correctly)
Comment 12 Michele Baldessari 2014-01-01 14:04:39 EST
pjw0701-fedoraforum,

it'd be best if you bring this issue up in the upstream mailing list on linuxtv.org as I don't see any recent commits in 3.13 git related to firmware
loading in drivers/media

thanks,
Michele

Note You need to log in before you can comment on or make changes to this bug.