Bug 963717 - R and friends needs an update
Summary: R and friends needs an update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: R
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 964293 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-16 13:11 UTC by Ranjan Maitra
Modified: 2013-06-03 19:31 UTC (History)
3 users (show)

Fixed In Version: R-3.0.1-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-28 02:22:03 UTC


Attachments (Terms of Use)

Description Ranjan Maitra 2013-05-16 13:11:31 UTC
Description of problem:

R has a new recommended update to fix some bugs and idiosyncracies introduced in earlier versions and should be updated from 3.0.0 to 3.0.1. (Please see 
http://cran.fhcrc.org/src/base/NEWS.html for more information.)

Update can be done from any mirror, such as:

http://cran.fhcrc.org/src/base/R-3/R-3.0.1.tar.gz

Happy to test, etc. as usual

Many thanks for maintaining R on Fedora!

Comment 1 Tom "spot" Callaway 2013-05-17 18:55:41 UTC
*** Bug 964293 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2013-05-19 02:50:55 UTC
rkward-0.6.1-2.fc18,rpy-2.3.6-2.fc18,R-3.0.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/rkward-0.6.1-2.fc18,rpy-2.3.6-2.fc18,R-3.0.1-2.fc18

Comment 3 Fedora Update System 2013-05-19 02:51:03 UTC
R-3.0.1-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/R-3.0.1-2.el6

Comment 4 Fedora Update System 2013-05-19 02:51:13 UTC
rkward-0.6.1-2.fc19,rpy-2.3.6-2.fc19,R-3.0.1-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/rkward-0.6.1-2.fc19,rpy-2.3.6-2.fc19,R-3.0.1-2.fc19

Comment 5 Fedora Update System 2013-05-19 18:19:03 UTC
Package rkward-0.6.1-2.fc19, rpy-2.3.6-2.fc19, R-3.0.1-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rkward-0.6.1-2.fc19 rpy-2.3.6-2.fc19 R-3.0.1-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8612/rkward-0.6.1-2.fc19,rpy-2.3.6-2.fc19,R-3.0.1-2.fc19
then log in and leave karma (feedback).

Comment 6 Ranjan Maitra 2013-05-20 12:07:39 UTC
Thanks! Just making sure: are R-core, R-devel, libRmath, libRmath-devel packages also updated?

Comment 7 Tom "spot" Callaway 2013-05-21 15:37:12 UTC
Yes, those are subpackages from R. The updates system only tracks the "src" names.

Comment 8 Fedora Update System 2013-05-28 02:22:03 UTC
rkward-0.6.1-2.fc19, rpy-2.3.6-2.fc19, R-3.0.1-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2013-05-29 00:59:18 UTC
rkward-0.6.1-2.fc18, rpy-2.3.6-2.fc18, R-3.0.1-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Ranjan Maitra 2013-05-30 02:12:05 UTC
Hi,

I am not sure that this is the right place to put in this feature request, but i was wondering if it is possible to package the vi plugin for R? I did put in an RFE here:

https://bugzilla.redhat.com/show_bug.cgi?id=967391

but not clear if the maintainer will look at it, given that he may have no interest in R.

Thanks!

Comment 11 Fedora Update System 2013-06-03 19:31:21 UTC
R-3.0.1-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.