Bug 963775 - scsi-cd: tray statuses (locked and open) are not reset on boot/reboot of guest
scsi-cd: tray statuses (locked and open) are not reset on boot/reboot of guest
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Pavel Hrdina
Virtualization Bugs
:
Depends On: 963773
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 10:19 EDT by Pavel Hrdina
Modified: 2013-07-01 12:04 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 963773
Environment:
Last Closed: 2013-07-01 12:04:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Hrdina 2013-05-16 10:19:30 EDT
+++ This bug was initially created as a clone of Bug #963773 +++

Description of problem:

If you reboot a guest which locks the tray of optical drive the optical drive stay locked.

How reproducible: 100%

Steps to Reproduce:
1. Boot a guest with media inserted in optical drive (for example fedora 17)
2. The media is auto-mounted and the optical drive is locked
3. Reboot the guest.
4. Before kernel is loaded (in GRUB time) the optical drive is locked
  
Actual results:
Before kernel is loaded the optical drive is locked.

Expected results:
Optical drive should not be locked.
Comment 2 Pavel Hrdina 2013-07-01 12:04:59 EDT
Fixed by commit 3abd71cd98deff0209fdacd2bb7583428914075d because of rebase to upstream qemu 1.5.1

Note You need to log in before you can comment on or make changes to this bug.