Bug 963819 - Back lit keyboard stops working after upgrade to 3.9.2
Back lit keyboard stops working after upgrade to 3.9.2
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 11:32 EDT by Andrew
Modified: 2014-06-23 09:48 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 11:03:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew 2013-05-16 11:32:10 EDT
Description of problem:
The keyboard backlight on Asus Q400a does not work after updating fedora.

Version-Release number of selected component (if applicable):
3.9.2-200

How reproducible:
Always


Steps to Reproduce:
1.Install update
2.reboot computer
3.
  
Actual results:
keyboard is not backlit.  It is for less than one second after booting, but lights turn off by the time grub menu is shown.

Expected results:
keyboard should be backlit.

Additional info:
I tried the solution here:
http://forums.fedoraforum.org/showthread.php?t=268249

where he said: "

Added file sony-laptop.conf with single line

options sony-laptop kbd_backlight=1

to /etc/modprobe.d/ and it seems to work fine now."

used asus-laptop instead of sony-laptop, but this doesn't work.
Comment 1 davide.salvatico 2013-05-25 05:53:35 EDT
Same here with ASUS N56V and kernels 3.9.2-200  3.9.3-200 3.9.3-201.
Comment 2 Dobmec 2013-05-28 17:57:52 EDT
I have an Asus ux31a, and I have the same issue with the backlit keyboard, as well as no more response from the sound control (Fn+f10, f11, f12) since the upgrade to kernel 3.9.2-200 or kernel 3.9.4-200.
All these functionalities were working out of the box with the previous kernels, and I can still use them by reverting to 3.8.x.
Strangely, the brightness controls (Fn+f5, f6, f7) still work (but are laggy) with this new kernel, whereas they were not working in kernel 3.6 (they had been added in 3.7).

It seems that this problem has also been noticed on archlinux:
https://bbs.archlinux.org/viewtopic.php?id=162643
Comment 3 YK 2013-06-08 14:27:17 EDT
Same also. Asus UX32VD with all kernels since 3.9.2. My backlit is blinking like a kernel panic. Only solution so far is to go back to the power consuming 3.8 kernel. Seems like a bug in asus_nb_wmi as it fails loading on boot.
Comment 4 Dobmec 2013-06-08 23:08:09 EDT
What is really strange is that yesterday, after a cold boot on kernel 3.9.4, the backlight and all the fn combinations were working. Unfortunately, I saw nothing unusual on the bootlog... And today, it's not working anymore :/
Comment 5 YK 2013-06-15 11:35:11 EDT
With 3.9.5-201 everything works as expected again for me.
Comment 6 Dobmec 2013-06-24 10:46:10 EDT
Even with the new 3.9.6-200, I still cannot use my fn keys...
Comment 7 Dobmec 2013-08-01 12:51:31 EDT
I have just updated to fedora 19 with kernel 3.10.3-300 and... the problem is still here :(
Comment 8 Dobmec 2013-08-04 11:51:58 EDT
Adding the line "modprobe asus-nb-wmi" in the file /etc/rc.modules solved the problem for me!
Comment 9 davide.salvatico 2013-08-04 14:41:15 EDT
Tried to adding the line as in your comment, but no ways.
When I press the keys appears the icon but the backlit is missing :-)
Comment 10 Hannes Ovrén 2013-08-08 05:21:33 EDT
Asus UX31A here. Booting the laptop produces the following relevant messages

asus_wmi: Initialization: 0x1
asus_wmi: BIOS WMI version: 7.9
asus_wmi: SFUN value: 0x4a2877
input: Asus WMI hotkeys as /devices/platform/asus-nb-wmi/input/input6
asus-nb-wmi: probe of asus-nb-wmi failed with error -5

I *can* load the asus-nb-wmi module manually using modprobe and then the hotkeys did respond. But they did so erratically. The effect pressing a hotkey had was basically random, so I removed the module again.

This is on Fedora 19 with kernel 3.10.4-300
Comment 11 davide.salvatico 2013-09-13 17:19:23 EDT
After upgrading to kernel-3.11.0-200.fc19 from koji.fedoraproject.org backlit is back and working.
fn keys work properly.
Comment 12 Justin M. Forbes 2013-10-18 17:14:01 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 18 kernel bugs.

Fedora 18 has now been rebased to 3.11.4-101.fc18.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 19, and are still experiencing this issue, please change the version to Fedora 19.

If you experience different issues, please open a new bug report for those.
Comment 13 Justin M. Forbes 2013-11-27 11:03:42 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  

It has been over a month since we asked you to test the 3.11 kernel updates and let us know if your issue has been resolved or is still a problem. When this happened, the bug was set to needinfo.  Because the needinfo is still set, we assume either this is no longer a problem, or you cannot provide additional information to help us resolve the issue.  As a result we are closing with insufficient data. If this is still a problem, we apologize, feel free to reopen the bug and provide more information so that we can work towards a resolution

If you experience different issues, please open a new bug report for those.
Comment 14 Andrew 2014-06-23 09:12:18 EDT
It currently works on my computer.
Comment 15 Hannes Ovrén 2014-06-23 09:48:42 EDT
On mine as well (Fedora 20).

Note You need to log in before you can comment on or make changes to this bug.