Bug 963876 - After update from Kernel 3.8.11-200.fc18 to 3.9.2-200.fc18, HDMI audio output is silent on ivy bridge system
After update from Kernel 3.8.11-200.fc18 to 3.9.2-200.fc18, HDMI audio output...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 13:23 EDT by Carl A. Adams
Modified: 2013-06-27 11:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-27 11:49:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl A. Adams 2013-05-16 13:23:42 EDT
Description of problem:
After update from Kernel 3.8.11-200.fc18 to 3.9.2-200.fc18, HDMI audio output is silent on IvyBridge system. Rebooting the system to the previous kernel (3.8.11-200.fc18) restores audio with no other changes to ALSA configuration.


Version-Release number of selected component (if applicable): 3.9.2-200.fc18


How reproducible: 100% (on my one system)


Steps to Reproduce:
1. Configure a system with working HDMI audio and a 3.8 series kernel.  Applications used for testing: XBMC and aplay.
2. Ensure that ALSA configuration us durable across reboots (So, doesn't appear to be a channel muting problem)
3. "yum update" to latest 3.9 series kernel
4. reboot.
5. No sound from either aplay or XBMC when playing a stereo source material. (Flac/CD rip - 44100 16-bit stereo).
6. Changing grub configuration to boot the older, series 3.8 kernel restores all sound operation with no other changes.
  

Actual results:
No sound from series 3.9 kernel over HDMI on IvyBridge system.


Expected results:
Series kernel 3.9 audio should work as well as kernel series 3.8.


Additional info:
I also noticed that alsamixer has one fewer output under 3.9 - "Smart 5.1" is missing.   Since this is muted anyway, I do not know if this is important.  

I did not observe any interesting in the dmesg or syslog. 

Tests were performed with XBMC 12.2 (built from source), and aplay (from yum)

System is an ASUS P8H77-I board with an i7-3770 IvyBridge CPU connected to a Denon AVR-2310CI receiver.
Comment 1 Carl A. Adams 2013-05-16 13:37:38 EDT
Additional information that I forgot to mention:  I am not using pulseaudio.  While libs and utils are installed, the sound server has been removed from this system and should not be anywhere in the audio stack.  This is true before and after the kernel update.
Comment 2 Carl A. Adams 2013-06-26 01:32:26 EDT
I've had some time to poke around with this, and I can add a little more color, but I am a little out of my depth regarding the guts of ALSA.

I've found that "aplay -D hdmi" also no longer worked, but that "aplay -D hdmi:CARD=PCH,DEV=1" *does* work.  The "DEV=1" (vs "DEV=0") seems to be an important difference between kernel 3.8.x and 3.9.x

XBMC 12.2 seems to be rather confused by this option, but that's not really your problem.
Comment 3 Carl A. Adams 2013-06-27 11:49:17 EDT
Closing as not a bug. Audio seems to work fine.  Applications were not working/configured well.

Note You need to log in before you can comment on or make changes to this bug.