Bug 963882 - pdfopt is missing
pdfopt is missing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 13:36 EDT by Ralf Corsepius
Modified: 2015-04-22 06:11 EDT (History)
3 users (show)

See Also:
Fixed In Version: ghostscript-9.07-10.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-20 05:36:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2013-05-16 13:36:59 EDT
Description of problem:

/usr/bin/pdfopt is missing from ghostscript in Fedora > 18.

The manpages referring to it are still being shipped:
# rpm -qlp ghostscript-9.07-2.fc19.x86_64.rpm | grep pdfopt
/usr/share/man/de/man1/pdfopt.1.gz
/usr/share/man/man1/pdfopt.1.gz

Version-Release number of selected component (if applicable):
ghostscript-9.07-2.fc19.x86_64

How reproducible:
cf. above.


Actual results:
The ghostscript package ships manpages without corresponding binaries.
Previous releases had contained /usr/bin/pdfopt

Expected results:
Either the manpages should not be shipped or the binary be added.
I don't know what is intended.

Additional info:
- Lack of pdfopt causes FTBFS of other packages.
Comment 1 Tim Waugh 2013-05-17 10:49:14 EDT
Enhancements to the pdfwrite driver have made pdfopt redundant so it was removed upstream.  They forgot to remove the manpages until after the 9.07 release.

Which packages are using pdfopt during build?
Comment 2 Ralf Corsepius 2013-05-17 11:29:01 EDT
(In reply to comment #1)
> Enhancements to the pdfwrite driver have made pdfopt redundant so it was
> removed upstream.  They forgot to remove the manpages until after the 9.07
> release.
I do not understand. How can a driver enhancement replace a script/program?

What are people, who have been using /usr/bin/pdfopt, supposed to use now?

> Which packages are using pdfopt during build?

I encountered this issue when investigating sdcc's FTBS
 https://bugzilla.redhat.com/show_bug.cgi?id=914508

For now, in sdcc, I resorted to using 
configure ... PDFOPT="/bin/cp"
which, as AFAICT, replaces running pdfopt in sdcc copying around files.

[Full story in sdcc's master in Fedora's git - I commited my sdcc changes and rebuilt sdcc just a couple of minutes ago]
Comment 3 Tim Waugh 2013-05-17 11:59:31 EDT
Here's the explanation in the commit log:

commit 260ddb3e53ffe852a8994dd00719931ca3f2beec
Author: Ken Sharp <ken.sharp@artifex.com>
Date:   Fri Sep 28 14:34:27 2012 +0100

    With the addition of linearisation to pdfwrite, pdfopt.ps has become
    redundant. Since it is difficult to maintain, has a number of bugs, and is
    believed not to work properly anyway, it is now deprecagted and hence
    removed from the repository.
Comment 4 Ralf Corsepius 2013-05-17 12:58:54 EDT
(In reply to comment #3)
> Here's the explanation in the commit log:
> 
> commit 260ddb3e53ffe852a8994dd00719931ca3f2beec
> Author: Ken Sharp <ken.sharp@artifex.com>
> Date:   Fri Sep 28 14:34:27 2012 +0100
> 
>     With the addition of linearisation to pdfwrite, pdfopt.ps has become
>     redundant. Since it is difficult to maintain, has a number of bugs, and
> is
>     believed not to work properly anyway, it is now deprecagted and hence
>     removed from the repository.

OK, they are saying pdfopt is functionally not required anymore.

They missed they have broken the UI, without prior warning or deprecation notice.
Comment 5 Fedora Update System 2013-07-17 12:28:33 EDT
ghostscript-9.07-10.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ghostscript-9.07-10.fc19
Comment 6 Fedora Update System 2013-07-18 01:47:07 EDT
Package ghostscript-9.07-10.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ghostscript-9.07-10.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13173/ghostscript-9.07-10.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-07-20 05:36:39 EDT
ghostscript-9.07-10.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Denis Rouzaud 2015-04-22 01:57:15 EDT
I can't find pdfopt on fedora 21.
I have ghostscript-9.15-6.fc21.x86_64 already installed.
Any idea?
Comment 9 Tim Waugh 2015-04-22 06:11:49 EDT
It was removed upstream - see comment #3.

Note You need to log in before you can comment on or make changes to this bug.