Bug 963899 - lightdm is misusing the preset file logic of systemd
lightdm is misusing the preset file logic of systemd
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lightdm (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 14:24 EDT by Lennart Poettering
Modified: 2013-10-05 22:22 EDT (History)
5 users (show)

See Also:
Fixed In Version: lightdm-1.6.2-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-05 22:22:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2013-05-16 14:24:18 EDT
This call tells me that lightdm.rpm is providing a preset file:

$ repoquery -q --qf="%{name}" --whatprovides '*/lib/systemd/system-preset/*.preset' | sort -u
...
lightdm
...

It shouldn't do that. Preset files are something that the distribution, spins of the distribution or administrators write. They policy that is applied to the OS, and should not be shipped by any normal RPMS. 

For Fedora, additions to the preset file must be kept in systemd.rpm and need to be accepted by FPC.

Please remove the preset file from the RPM. Thanks!
Comment 1 Fedora Update System 2013-05-20 22:05:16 EDT
lightdm-1.6.0-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-8422/lightdm-1.6.0-6.fc19
Comment 2 Fedora Update System 2013-05-21 13:18:15 EDT
Package lightdm-1.6.0-6.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lightdm-1.6.0-6.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8422/lightdm-1.6.0-6.fc19
then log in and leave karma (feedback).
Comment 3 Adam Williamson 2013-05-21 20:57:27 EDT
I can't quite see why, but 'fixing' this seems to have broken default activation of lightdm. It's listed in /usr/lib/systemd/system-preset/90-display-manager.preset and the package scripts look to be in order, but if I build a MATE live image with 1.6.0-5 then it boots to MATE, but if I build one with 1.6.0-6 or 1.6.0-7, it boots to a console, and 'systemctl status lightdm.service' shows it disabled and not running. 'systemctl start lightdm.service' brings MATE up.
Comment 4 Rex Dieter 2013-05-21 23:29:10 EDT
I'll revert the change for this, until the issues with it can be sorted out.
Comment 5 Lennart Poettering 2013-06-06 06:35:48 EDT
Hmm, I guess 

https://bugzilla.redhat.com/show_bug.cgi?id=903690#c7

is the explanation here. Will fix this shortly.
Comment 6 Fedora Update System 2013-06-06 06:39:02 EDT
systemd-204-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/systemd-204-5.fc19
Comment 7 Rex Dieter 2013-06-06 07:58:32 EDT
I get "Access denied" trying to view bug #903690
Comment 8 Fedora Update System 2013-06-06 08:44:28 EDT
systemd-204-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/systemd-204-6.fc19
Comment 9 Fedora Update System 2013-06-06 13:30:29 EDT
Package systemd-204-6.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-204-6.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10202/systemd-204-6.fc19
then log in and leave karma (feedback).
Comment 10 Adam Williamson 2013-06-06 15:46:53 EDT
rdieter: that comment doesn't look private, so I'll reproduce it here:

"If I understand presets correctly, any product specific preset can be named:

/lib/systemd/system-preset/<NUMBER < 90>-<PRODUCT>.preset

e.g.:

/lib/systemd/system-preset/80-RHEL-7-VARIANT-A.preset

as long as it has a catchall wildcard as the last line:
disable *

... which makes me question /lib/systemd/system-preset/90-display-manager.preset 

which should not have any effect due to 
disable *
in /lib/systemd/system-preset/90-default.preset"
Comment 11 Fedora Update System 2013-06-07 23:36:47 EDT
systemd-204-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Adam Williamson 2013-06-08 00:43:10 EDT
Re-opening, because I think system 204-6 doesn't actually fix the bug that lightdm includes a preset file, right? It just makes it possible for us to take the preset out of lightdm package without breaking anything. IIUC. So now it's on Rex.
Comment 13 Rex Dieter 2013-10-05 22:22:59 EDT
* Tue Aug 20 2013 Rex Dieter <rdieter@fedoraproject.org> 1.6.0-11
- remove systemd preset (#963899)


commit/fix got rolled into update
https://admin.fedoraproject.org/updates/FEDORA-2013-16388/lightdm-1.6.2-1.fc19

Note You need to log in before you can comment on or make changes to this bug.