Bug 963909 - Update to 2.24.3-1 breaks VMWare Workstation
Update to 2.24.3-1 breaks VMWare Workstation
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gtkmm24 (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Haïkel Guémar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 14:41 EDT by Scott Brown
Modified: 2013-05-18 00:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-18 00:53:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 700495 None None None Never

  None (edit)
Description Scott Brown 2013-05-16 14:41:49 EDT
Description of problem: After update to 2.24.3-1 VMWare Workstation 9.0.2 opens with a blank white window. Eventually a Force Quit dialog is presented to kill the unresponsive program.


Version-Release number of selected component (if applicable): 2.24.3-1


How reproducible: Always


Steps to Reproduce:
1. Update gtkmm24 to 2.24.3-1
2. Start VMWare Workstation
  
Actual results: Program fails to start

 
Expected results: Program runs


Additional info: "yum downgrade gtkmm24" to downgrade to 2.24.2-5 fixes the problem. I also found a report here which is what made me try the gtkmm24 downgrade: https://aur.archlinux.org/packages/vmware-workstation/
Comment 1 Kalev Lember 2013-05-16 19:45:11 EDT
Hi Scott,

Thanks for the report! Any chance you would be willing to report this to upstream as well? They are planning a new 2.24.4 release to fix some regressions in 2.24.3, and as far as I know your issue hasn't been reported there yet.

I can do that as well if you don't want to, but you'd be in a much better position since you are actually using VMWare Workstation.

https://bugzilla.gnome.org/enter_bug.cgi?product=gtkmm&version=2.24.x

Thanks!
Comment 2 Scott Brown 2013-05-16 20:18:16 EDT
(In reply to comment #1)

> Thanks for the report! Any chance you would be willing to report this to
> upstream as well? They are planning a new 2.24.4 release to fix some
> regressions in 2.24.3, and as far as I know your issue hasn't been reported
> there yet.

Done. I also updated the bug with the reference to the bug ID @ gnome.
Comment 3 Scott Brown 2013-05-17 17:32:48 EDT
(In reply to comment #2)
> (In reply to comment #1)
> 
> > Thanks for the report! Any chance you would be willing to report this to
> > upstream as well? They are planning a new 2.24.4 release to fix some
> > regressions in 2.24.3, and as far as I know your issue hasn't been reported
> > there yet.
> 
> Done. I also updated the bug with the reference to the bug ID @ gnome.

Not sure if you saw this from upstream:

Murray Cumming [gtkmm developer] 2013-05-17 10:28:00 UTC

CCing Hubert, who made this release.

I have no idea what might be causing this, but the 2.24.3 release seems to
generally be a disaster, and I recommend that any distro does not try to
package it for now.
Comment 4 Rahul Sundaram 2013-05-17 17:40:56 EDT
kalev, this release is still only in testing.  we can pull that update and send a note to fedora test list not to use this package.  I don't think a epoch and downgrade is needed here
Comment 5 Kalev Lember 2013-05-17 17:46:05 EDT
Yep, I've unpushed the F19 update now, so it should soon disappear from the mirrors. Good thing that we have the updates-testing safeguard and thanks for pointing out the issues, Scott!

Note You need to log in before you can comment on or make changes to this bug.