Bug 963915 - please remove +x bit from systemd unit file
please remove +x bit from systemd unit file
Status: CLOSED DUPLICATE of bug 803980
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
19
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 14:43 EDT by Zbigniew Jędrzejewski-Szmek
Modified: 2014-11-01 09:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-01 09:40:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zbigniew Jędrzejewski-Szmek 2013-05-16 14:43:52 EDT
The unit file is not executable, and should not be marked +x. C.f. https://fedoraproject.org/wiki/Packaging:Guidelines#File_Permissions.

-rwxr-xr-x. 1 root root 365 Apr  1 18:40 /usr/lib/systemd/system/wpa_supplicant.service
wpa_supplicant-2.0-1.fc19.x86_64
Comment 1 poma 2014-11-01 05:41:53 EDT
- Configuration file /usr/lib/systemd/system/wpa_supplicant.service is marked executable.
  https://bugzilla.redhat.com/show_bug.cgi?id=1159084

- No need to set the service(configuration) file as an executable.
  https://bugzilla.redhat.com/show_bug.cgi?id=1157200

- Execute permission on wpa_supplicant.service unit file
  https://bugzilla.redhat.com/show_bug.cgi?id=1146014

- Wrong perms on systemd service file
  https://bugzilla.redhat.com/show_bug.cgi?id=803980
Comment 2 Michael Catanzaro 2014-11-01 09:40:45 EDT

*** This bug has been marked as a duplicate of bug 803980 ***

Note You need to log in before you can comment on or make changes to this bug.