Bug 963967 - Root password spoke in initial-setup seems useless
Root password spoke in initial-setup seems useless
Status: CLOSED DUPLICATE of bug 963935
Product: Fedora
Classification: Fedora
Component: initial-setup (Show other bugs)
19
All All
unspecified Severity medium
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 18:07 EDT by Adam Williamson
Modified: 2013-05-21 13:20 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-21 13:20:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2013-05-16 18:07:15 EDT
Thinking more about initial-setup logic...

We still don't let you out of anaconda without setting a root password or creating an admin user. So why have that spoke in initial-setup? It seems pointless.

Okay, so we could make it optional in anaconda and pop up initial-setup if you don't do it in anaconda, that would be the other option. But that just seems more complex and confusing. And I don't think it works well with gnome-initial-setup. g-i-s can't set the root password, so I think if we let you out of anaconda if you'd created a non-admin user account and not set a root password, the GNOME path would break.

Honestly, thinking through all these anaconda/i-s/g-i-s logic thickets is getting ludicrous. There has to be a better way.
Comment 1 Adam Williamson 2013-05-21 13:20:23 EDT
OK, now I know what the plan is here, let's make it all one bug.

*** This bug has been marked as a duplicate of bug 963935 ***

Note You need to log in before you can comment on or make changes to this bug.