Bug 963986 - Standalone.bat does not work if quote characters are on path to EAP
Standalone.bat does not work if quote characters are on path to EAP
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Scripts and Commands (Show other bugs)
6.1.0
Unspecified Windows
unspecified Severity high
: ER3
: EAP 6.2.0
Assigned To: James Perkins
:
Depends On: 916960
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 20:10 EDT by Russell Dickenson
Modified: 2013-12-15 11:14 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 916960
Environment:
windows
Last Closed: 2013-12-15 11:14:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Dickenson 2013-05-16 20:10:52 EDT
+++ This bug was initially created as a clone of Bug #916960 +++

While investigating and testing possible solutions to the bug mentioned above, further issues with the script were found.

If you have defined a JBOSS_HOME environment variable, it executes differently depending on whether it is defined with quotes or without quotes. For example:

SET JBOSS_HOME="C:\Program Files (x86)\jboss-eap-6.1"
runs into an issue with this line:

if "x%JBOSS_HOME%" == "x"

SET JBOSS_HOME=C:\Program Files (x86)\jboss-eap-6.1 
runs into other issues.

"C:\Program Files (x86)\EAP-6.1.0" is default installation path on windows (when using installer). User won't be able to run EAP in standalone mode neither by using start-menu shortcut nor by directly invoking standalone.bat script, if he choose default installation path.
Comment 1 James Perkins 2013-09-20 14:48:47 EDT
This seems to be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=916960, but this one contains all the ACK's so I'm giving the devel_ack+ here.
Comment 5 Petr Kremensky 2013-10-08 06:23:51 EDT
I was able to start server without any issue using both options:
set JBOSS_HOME="W:\pkremens\Program Files (x86)\jboss-eap-6.2"
set JBOSS_HOME=W:\pkremens\Program Files (x86)\jboss-eap-6.2

Verified on EAP 6.2.0.ER5.

Note You need to log in before you can comment on or make changes to this bug.