Bug 964032 - root-squash: root-squashing does not get disabled dynamically
root-squash: root-squashing does not get disabled dynamically
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.0
Unspecified Unspecified
high Severity urgent
: ---
: ---
Assigned To: Raghavendra Bhat
Saurabh
:
Depends On: 927616 927630
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-17 02:00 EDT by Raghavendra Bhat
Modified: 2016-01-19 01:11 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.3.0.8rhs-1
Doc Type: Bug Fix
Doc Text:
Cause: the option to disable root-squash feature was not handled properly in server protocol module. Consequence: if 'root-squash' feature was added to a volume, one couldn't disable it while the volume was running, it needed a restart to take effect. Fix: the particular option to disable the root-squashing is now handled in server-protocol and RPC layer is made aware of the same. Result: with the added fix, now admin can disable the root-squash feature on the live volume.
Story Points: ---
Clone Of: 927630
Environment:
Last Closed: 2013-07-15 17:52:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 5 errata-xmlrpc 2013-07-15 17:52:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1064.html

Note You need to log in before you can comment on or make changes to this bug.