Bug 964044 - serious CPU time regressions in the glibc math library
serious CPU time regressions in the glibc math library
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glibc (Show other bugs)
6.4
x86_64 Linux
urgent Severity high
: rc
: ---
Assigned To: Carlos O'Donell
Miroslav Franc
: ZStream
Depends On: 929388
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-17 02:54 EDT by Libor Miksik
Modified: 2016-11-24 07:06 EST (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A fix to prevent logic errors in various mathematical functions, including exp, exp2, expf, exp2f, pow, sin, tan, and rint, caused by inconsistent results when the functions were used with the non-default rounding mode , creates performance regressions for certain inputs. The performance regressions have been analyzed and the core routines have been optimized to bring performance back to reasonable levels.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-11 09:39:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Miksik 2013-05-17 02:54:11 EDT
This bug has been copied from bug #929388 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 21 errata-xmlrpc 2013-07-11 09:39:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1046.html

Note You need to log in before you can comment on or make changes to this bug.