Bug 964069 - Anaconda creates native partition in text mode if LVM or btrfs is selected
Anaconda creates native partition in text mode if LVM or btrfs is selected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
All Unspecified
medium Severity medium
: ---
: ---
Assigned To: Samantha N. Bueno
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F19Beta/F19BetaBlocker F19Blocker/F19FinalBlocker fedora19rtt
  Show dependency treegraph
 
Reported: 2013-05-17 04:06 EDT by Pavel Holica
Modified: 2013-05-29 03:28 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 03:28:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
textmode-lvm.txt (9.82 KB, text/plain)
2013-05-17 04:06 EDT, Pavel Holica
no flags Details
anaconda.ifcfg.log (661 bytes, text/plain)
2013-05-17 04:27 EDT, Pavel Holica
no flags Details
anaconda.log (8.64 KB, text/plain)
2013-05-17 04:27 EDT, Pavel Holica
no flags Details
anaconda.packaging.log (86.34 KB, text/plain)
2013-05-17 04:27 EDT, Pavel Holica
no flags Details
anaconda.program.log (45.39 KB, text/plain)
2013-05-17 04:27 EDT, Pavel Holica
no flags Details
anaconda.storage.log (169.67 KB, text/plain)
2013-05-17 04:27 EDT, Pavel Holica
no flags Details
syslog (50.30 KB, text/plain)
2013-05-17 04:27 EDT, Pavel Holica
no flags Details

  None (edit)
Description Pavel Holica 2013-05-17 04:06:04 EDT
Created attachment 749209 [details]
textmode-lvm.txt

Description of problem:
In text mode, I've selected LVM (default) partition scheme, but anaconda started to create native partitions.

Version-Release number of selected component (if applicable):
anaconda-19.28-1.fc19

How reproducible:
always

Steps to Reproduce:
1. Start text installation
2. When asked for "Partition Scheme Options" select LVM (default)
3. continue with installation
  
Actual results:
Progress
Setting up the installation environment
.
Creating disklabel on /dev/sda
.
Creating swap on /dev/sda2
.
Creating ext4 on /dev/sda5
.
Creating ext4 on /dev/sda3
.
Creating ext4 on /dev/sda1
.
Starting package installation process
...

Expected results:
LVM pv and lvs are created.

Additional info:
Attaching full progress.
Comment 1 Pavel Holica 2013-05-17 04:27:05 EDT
Created attachment 749223 [details]
anaconda.ifcfg.log
Comment 2 Pavel Holica 2013-05-17 04:27:08 EDT
Created attachment 749224 [details]
anaconda.log
Comment 3 Pavel Holica 2013-05-17 04:27:12 EDT
Created attachment 749225 [details]
anaconda.packaging.log
Comment 4 Pavel Holica 2013-05-17 04:27:16 EDT
Created attachment 749226 [details]
anaconda.program.log
Comment 5 Pavel Holica 2013-05-17 04:27:20 EDT
Created attachment 749227 [details]
anaconda.storage.log
Comment 6 Pavel Holica 2013-05-17 04:27:28 EDT
Created attachment 749228 [details]
syslog
Comment 7 Pavel Holica 2013-05-17 04:35:30 EDT
I also forgot to mention, that this happens on Fedora 19 Beta RC2.
Comment 8 Pavel Holica 2013-05-17 04:47:29 EDT
Ok, and anaconda ignores btrfs if selected too.
Comment 9 Adam Williamson 2013-05-17 17:12:55 EDT
This looks like a good candidate for Beta FE at least. You could argue it as a Beta blocker, but it's a close thing.
Comment 10 Samantha N. Bueno 2013-05-17 19:23:16 EDT
Patch posted to anaconda-patches list.
Comment 11 Adam Williamson 2013-05-17 19:28:07 EDT
Okay, let's at least consider this one as a blocker. Criteria:

https://fedoraproject.org/wiki/Fedora_19_Alpha_Release_Criteria#Installation_interfaces

"When using the dedicated installer images, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces."

https://fedoraproject.org/wiki/Fedora_19_Beta_Release_Criteria#Guided_partitioning

"When using the guided partitioning flow, the installer must be able to...Complete an installation using any combination of disk configuration options it allows the user to select"

We're in the guided flow in the text installer, it offers these options, but doesn't honor them.
Comment 12 Samantha N. Bueno 2013-05-17 19:44:51 EDT
Patch pushed, commit e80477fcada25d5fed609a902107759e4ce0d16c
Comment 13 Adam Williamson 2013-05-20 12:33:46 EDT
Discussed at 2013-05-20 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-20/f19beta-blocker-review-7.2013-05-20-16.07.log.txt . Accepted as a Beta blocker per rationale in comment #11.
Comment 14 Fedora Update System 2013-05-21 19:35:08 EDT
anaconda-19.29-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.29-1.fc19
Comment 15 Vojtěch Boček 2013-05-22 04:55:01 EDT
Tested on Fedora Beta RC3 netinst with anaconda 19.29-1, it works - anaconda correctly creates native, LVM and btrfs partitions when selected.
Comment 16 Adam Williamson 2013-05-23 13:38:37 EDT
still fixed in RC4.
Comment 17 Jay Greguske 2013-05-23 16:13:35 EDT
will this stay fixed in rc5?
Comment 18 Samantha N. Bueno 2013-05-23 16:28:09 EDT
(In reply to Jay Greguske from comment #17)
> will this stay fixed in rc5?

It's tough to say, really--in a perfect world, yes.
Comment 19 Adam Williamson 2013-05-24 00:06:01 EDT
There isn't going to be an RC5.
Comment 20 Kamil Páral 2013-05-29 03:28:31 EDT
anaconda 19.30 is stable, closing.

Note You need to log in before you can comment on or make changes to this bug.