Bug 964085 - [Card558]sometimes oo-admin-fix can't find the error Used UIDs not reserved and fix this error
[Card558]sometimes oo-admin-fix can't find the error Used UIDs not reserved a...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-17 04:22 EDT by Rony Gong
Modified: 2015-05-14 20:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 00:05:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rony Gong 2013-05-17 04:22:22 EDT
Description of problem:
sometimes Can't find the error case "IDs that are available in the district but a gear using that UID already exists on a node within the district" by oo-admin-fix



make the case:
UIDs that are available in the district but a gear using that UID already exists on a node within the district.
Then run oo-admin-fix --district-uids
It just return Success.

seems Dev need update the algorithm of find the mismatch uid between available_uids and app's real uid in application collection.

Since I find the oo-admin-fix result has returned success already,  but the develpment.log still showing searching uid in application collection, the development.log is still writing.

eg:
2013-05-17 04:16:28.720 [DEBUG] MOPED: 127.0.0.1:27017 QUERY        database=openshift_broker_dev collection=districts selector={"uuid"=>"c81bb5dabe9311e28eed22000a98bab4", "available_uids"=>6988} flags=[] limit=1 skip=0 batch_size=nil fields={:_id=>1} (0.6959ms) (pid:31108)



Version-Release number of selected component (if applicable):
devenv_3235

How reproducible:
Always

Steps to Reproduce:
1.Create multi node env, 1 district and 2 nodes added to this district
2.Create one application(uid=2443)
3.Add  the uid=2443  back to district avaialble_uids in mongodb
4.run oo-admin-fix --district-uids
  
Actual results:
[root@ip-10-152-186-180 ~]# oo-admin-fix --district-uids 
Started at: 2013-05-17 01:21:41 -0400
Time to fetch mongo data: 0.026s
Total gears found in mongo: 2
Success
Total time: 12.798s
Finished at: 2013-05-17 01:21:54 -0400


Expected results:
Could find and  fix this kind of error successfully.

Additional info:
I only successed used this oo-admin-fix 1 time, still find the reason now.
Comment 1 Abhishek Gupta 2013-05-17 16:00:25 EDT
I was unable to reproduce this problem on devenv_3240. Can you please retry on the latest devenv?
Comment 2 Rony Gong 2013-05-20 07:56:17 EDT
Verified on devenv_3247
Can't reproduced this error any more.

Note You need to log in before you can comment on or make changes to this bug.