This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 964096 - Create user is marked as configured when no user is created in text mode
Create user is marked as configured when no user is created in text mode
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Samantha N. Bueno
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F19Blocker/F19FinalBlocker fedora19rtt
  Show dependency treegraph
 
Reported: 2013-05-17 04:41 EDT by Pavel Holica
Modified: 2013-05-24 13:21 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 13:21:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
textmode-lvm.txt (9.82 KB, text/plain)
2013-05-17 04:41 EDT, Pavel Holica
no flags Details
anaconda.ifcfg.log (661 bytes, text/plain)
2013-05-17 04:41 EDT, Pavel Holica
no flags Details
anaconda.log (8.64 KB, text/plain)
2013-05-17 04:41 EDT, Pavel Holica
no flags Details
anaconda.packaging.log (86.34 KB, text/plain)
2013-05-17 04:41 EDT, Pavel Holica
no flags Details
anaconda.program.log (45.39 KB, text/plain)
2013-05-17 04:41 EDT, Pavel Holica
no flags Details
anaconda.storage.log (169.67 KB, text/plain)
2013-05-17 04:41 EDT, Pavel Holica
no flags Details
syslog (50.30 KB, text/plain)
2013-05-17 04:42 EDT, Pavel Holica
no flags Details

  None (edit)
Description Pavel Holica 2013-05-17 04:41:11 EDT
Created attachment 749240 [details]
textmode-lvm.txt

Description of problem:
In text mode, before root password is set, both "create user" and "set root password" have [!]. Once "set root password" is set, both have [x], but "create user" has not jet been configured.

Version-Release number of selected component (if applicable):
Fedora 19 Beta RC2
anaconda-19.28-1.fc19

How reproducible:
always

Steps to Reproduce:
1. Start text mode installation
2. don't create user but set root password
3. continue with installation
  
Actual results:
Installation

 1) [x] Timezone settings                 2) [x] Install Destination
        (Europe/Luxembourg timezone)             (Automatic partitioning selecte
 3) [x] Create user                              d)
        (No user will be created)         4) [x] Set root password
                                                 (Password is set.)
  Please make your choice from above ['q' to quit | 'c' to continue]: 

Expected results:
Installation

 1) [x] Timezone settings                 2) [x] Install Destination
        (Europe/Luxembourg timezone)             (Automatic partitioning selecte
 3) [ ] Create user                              d)
        (No user will be created)         4) [x] Set root password
                                                 (Password is set.)
  Please make your choice from above ['q' to quit | 'c' to continue]: 

Additional info:
Attaching full installation progress.
Comment 1 Pavel Holica 2013-05-17 04:41:31 EDT
Created attachment 749242 [details]
anaconda.ifcfg.log
Comment 2 Pavel Holica 2013-05-17 04:41:40 EDT
Created attachment 749243 [details]
anaconda.log
Comment 3 Pavel Holica 2013-05-17 04:41:45 EDT
Created attachment 749244 [details]
anaconda.packaging.log
Comment 4 Pavel Holica 2013-05-17 04:41:48 EDT
Created attachment 749245 [details]
anaconda.program.log
Comment 5 Pavel Holica 2013-05-17 04:41:54 EDT
Created attachment 749246 [details]
anaconda.storage.log
Comment 6 Pavel Holica 2013-05-17 04:42:00 EDT
Created attachment 749248 [details]
syslog
Comment 7 Brian Lane 2013-05-23 16:23:27 EDT
This indicates that the spoke doesn't need to be visited. Note that it does say "(No user will be created)" below it. I'm not sure if we want to change this or not.
Comment 8 Samantha N. Bueno 2013-05-23 21:54:11 EDT
(In reply to Brian C. Lane from comment #7)
> This indicates that the spoke doesn't need to be visited. Note that it does
> say "(No user will be created)" below it. I'm not sure if we want to change
> this or not.

We probably should, yes.
Comment 9 Samantha N. Bueno 2013-05-24 13:21:41 EDT
I take back my previous comment. Text behavior mirrors what is seen in graphical install. I see no reason to change that and break consistency. As far as I am concerned this is not a bug.

Note You need to log in before you can comment on or make changes to this bug.