Bug 964099 - [Doc Bug Fix] Document: How to configure JMS Bridge
[Doc Bug Fix] Document: How to configure JMS Bridge
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity high
: ER8
: EAP 6.3.0
Assigned To: sgilda
Russell Dickenson
: Documentation, FutureFeature
: 999344 1089277 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-17 04:46 EDT by Nikoleta Ziakova
Modified: 2016-09-01 04:09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-28 11:37:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikoleta Ziakova 2013-05-17 04:46:21 EDT

    
Comment 2 Scott Mumford 2014-02-04 22:48:28 EST
Please provide a description of what would be needed in this documentation, or a URL to existing information that can be used as a base.
Comment 4 Martin Svehla 2014-02-05 02:53:33 EST
You can find some informations in discussion in bug 999344 as well
Comment 5 Martin Svehla 2014-02-05 02:54:03 EST
*** Bug 999344 has been marked as a duplicate of this bug. ***
Comment 6 Scott Mumford 2014-02-10 18:23:44 EST
Thanks Martin.
Comment 7 sgilda 2014-06-03 15:18:03 EDT
I can take this one.
Comment 8 sgilda 2014-06-03 16:16:48 EDT
Started the topic here: Create a JMS Bridge [34417]
Comment 9 Miroslav Novak 2014-06-04 03:04:44 EDT
Hi Sande,

there is already chapter about JMS bridges in Migration Guide [1] - in Procedure 3.18. Configure the JMS Bridge deployed to a JBoss EAP 6.x Server.

We could provide link just to this doc. Relevant is really just the second procedure "3.18. Configure the JMS Bridge deployed to a JBoss EAP 6.x Server"

Thanks,
Mirek

[1] http://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6.3/html-single/Migration_Guide/index.html#Configure_a_JMS_Bridge_to_Migrate_Existing_JMS_Messages_to_Enterprise_Application_Platform_6
Comment 10 sgilda 2014-06-04 10:46:50 EDT
Hi Mirek,

I thought it sounded familiar. Yes, I wrote that topic 2 or 3 years ago. :-)

I think I need to break that topic into multiple topics. Then the one portion could be included in the Administration and Configuration Guide or the Development Guide. 

Thanks for the reminder!
Sande
Comment 11 sgilda 2014-06-04 14:39:08 EDT
I removed the procedures from the the existing topic: Configure a JMS Bridge to Migrate Existing JMS Messages to JBoss EAP 6 [9374]

I created a new topic: Create a JMS Bridge [34417]

The topic title makes it more generic so it can be used in any guide.
Comment 13 Miroslav Novak 2014-06-05 04:50:10 EDT
Hi Sande,

I can see there is also chapter "Configuring HornetQ JMS Bridge [31365]" in Section: Configuration. Can you merge it with it what is already there. Configuration from migration guide appears to be more detailed.

Thanks,
Mirek
Comment 14 sgilda 2014-06-05 08:17:11 EDT
Hi Mirek,

That section is "Configuration" and I think the topic that is there has a little different viewpoint. The new topic is more of a 'how-to' use case. I think merging the separate topics into one topic might make it too complex. 

I think there are 2 options:

1) Add the new topic to the section I noted above, but add a note at the end of the existing topic "Configuring HornetQ JMS Bridge" that says:

     For more complete instructions, see "How to Create a JMS Bridge".
OR

     For more information, see the section entitled "JMS Bridges".

2) Add the new topic to the section you mention, but keep it separate:

  Section: Configuration
    Configure the JMS Server [111]
    Configure JMS Address Settings [8537]
    Configure Messaging with HornetQ [4371]
    Configuring HornetQ Core Bridge [31325]
    Configuring HornetQ JMS Bridge [31365]
    Create a JMS Bridge [34417]       <!-- NEW TOPIC            -->
    Configure Delayed Redelivery [640]
    Configure Dead Letter Addresses [643]
    Configure Message Expiry Addresses [650]
    Reference for HornetQ Configuration Attributes [9087]
    Set Message Expiry [649]

My preference is number 1), but I will defer to your opinion. :-)

Thanks,
Sande
Comment 15 Miroslav Novak 2014-06-05 08:33:15 EDT
You're right, I'm for first option:
1) Add the new topic to the section I noted above, but add a note at the end of the existing topic "Configuring HornetQ JMS Bridge" that says:

     For more complete instructions, see "How to Create a JMS Bridge".

Thanks,
Mirek
Comment 17 Miroslav Novak 2014-06-05 09:30:48 EDT
I can see the link in chapter 18.6.4 and not in 18.6.5. Configuring HornetQ JMS Bridge. Otherwise it looks ok to me.
Comment 19 sgilda 2014-06-06 07:25:25 EDT
*** Bug 1089277 has been marked as a duplicate of this bug. ***
Comment 21 Martin Svehla 2014-06-13 08:48:55 EDT
Sande,

(not bug, but point for discussion)

Do we want to have such a detailed description on setting a bridge on EAP5 in Administration Guide? I mean it's not really relevant to EAP6 administration and we already have it in Migration Guide.

I would split whole "Procedure 18.1. Create a JMS Bridge" in chapter 18.8.2 into two:

 - First one with the current "Configure the Bridge on the Destination JBoss EAP 6 Server". Change the header to "Configure the Bridge deployed on JBoss EAP 6 Server" (dropping the word "destination", it's not needed here, since it shouldn't be about migration only). I also think we can drop "Since JBoss 6.1 and later,..." from the first paragraph (since it's documentation for 6.3 only).

 - Second one would be only part (d) from current "Configure the Bridge on the Source JBoss EAP 5.x Server", because that's basically the only relevant part for EAP6. Name it something like "JAR files you need for bridges deployed on other application servers".
Comment 22 sgilda 2014-06-13 17:13:21 EDT
Hi Martin,

This topic is used in 2 guides. What I could do is add conditional logic so that the JBoss EAP 5 source bridge only appears in the Migration Guide and a generic "Configure your source" appears in the Administration Guide.

Would that be better?

Thanks,
Sande
Comment 23 Martin Svehla 2014-06-16 03:53:10 EDT
Sande,

Sounds reasonable. Can you draft it on docbuilder so we can check how it looks like that? Thanks!
Comment 29 Martin Svehla 2014-06-20 10:11:48 EDT
Thanks Sande

Note You need to log in before you can comment on or make changes to this bug.