Bug 964172 - dmraid should not be running in the default boot
dmraid should not be running in the default boot
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: dmraid (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
: 1039781 (view as bug list)
Depends On:
Blocks: WhyWeBootSoSlow
  Show dependency treegraph
 
Reported: 2013-05-17 08:23 EDT by Lennart Poettering
Modified: 2013-12-10 07:20 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-10 07:20:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2013-05-17 08:23:45 EDT
Currently, "dmraid" is pulled into the boot process on all installations. Since dmraid pulls in udev-settle this causes major slow-down for most boots - for functionality only a small minority actually use.

We really should find a way to get this out of the boot. Hans de Goede suggested the following solution:

https://lists.fedoraproject.org/pipermail/devel/2013-May/182911.html
Comment 1 Lennart Poettering 2013-05-17 08:29:34 EDT
I also filed this bug to get dmraid not even installed from anaconda:

https://bugzilla.redhat.com/show_bug.cgi?id=964175

But since that won't solve the problems for livecds we still need that dmraid uses a condition check to get skipped when it isn't needed, the way Hans suggested in the mail above.
Comment 2 Heinz Mauelshagen 2013-05-17 08:33:36 EDT
(In reply to comment #0)
> Currently, "dmraid" is pulled into the boot process on all installations.
> Since dmraid pulls in udev-settle this causes major slow-down for most boots
> - for functionality only a small minority actually use.
> 
> We really should find a way to get this out of the boot. Hans de Goede
> suggested the following solution:
> 
> https://lists.fedoraproject.org/pipermail/devel/2013-May/182911.html

Hans' solution copes with temporary unavailable RAID sets as well, so yes, looks good to me.
Comment 3 Michal Schmidt 2013-05-17 08:40:24 EDT
Conditions are evaluated just before starting the service, so that won't prevent the pulling in of the udev-settle dependency, will it?
Comment 4 Lennart Poettering 2013-05-17 12:08:54 EDT
Michal's right.

Heinz, relying on udev-settle is really broken. It's a broken concept and delays the boot for quite some time. Any chance this can be fixed? dm-raid should act as soon as devices show up rather then assume it is invoked after all devices have shown. Which is a point in time which doesn't even exist...
Comment 6 Peter Rajnoha 2013-12-10 06:17:32 EST
*** Bug 1039781 has been marked as a duplicate of this bug. ***
Comment 7 Heinz Mauelshagen 2013-12-10 07:20:10 EST
dmraid is not installed for normal installations by default any more, so it's not a general issue.

Users should disable the service on live systems if they don't use dmraid supported RAID sets at all.

On live media dmraid can be used conditionally outside the scope of systemd if it's required to support an installation destionation.

Note You need to log in before you can comment on or make changes to this bug.