Bug 964183 - texlive-pdfcrop should require ghostscript, but it doesn't
texlive-pdfcrop should require ghostscript, but it doesn't
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: texlive (Show other bugs)
18
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-17 08:47 EDT by Yury V. Zaytsev
Modified: 2013-07-08 21:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: texlive-2013-0.1.20130608_r30832.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 21:38:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yury V. Zaytsev 2013-05-17 08:47:05 EDT
Description of problem:

After installing texlive-pdfcrop on a clean system, it exits with an error message:

    $ pdfcrop x.pdf y.pdf
    PDFCROP 1.38, 2012/11/02 - Copyright (c) 2002-2012 by Heiko Oberdiek.
    !!! Error: Ghostscript exited with error code 127!

This happens, because it internally relies on ghostscript, but it's missing from the Requires.

Version-Release number of selected component (if applicable):

texlive-pdfcrop-svn29348.1.37-20.fc18.noarch

How reproducible:

See above.
Comment 1 Fedora Update System 2013-06-14 01:35:48 EDT
texlive-2013-0.1.20130608_r30832.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/texlive-2013-0.1.20130608_r30832.fc19
Comment 2 Fedora Update System 2013-06-14 01:44:02 EDT
texlive-2013-0.1.20130608_r30832.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/texlive-2013-0.1.20130608_r30832.fc18
Comment 3 Fedora Update System 2013-06-14 19:12:21 EDT
Package texlive-2013-0.1.20130608_r30832.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing texlive-2013-0.1.20130608_r30832.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10849/texlive-2013-0.1.20130608_r30832.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-07-08 21:38:34 EDT
texlive-2013-0.1.20130608_r30832.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.