Bug 964202 - Error on attempt to add connection definitions to a resource adapter if the there are resource adapters with the same name configured in another profile [NEEDINFO]
Error on attempt to add connection definitions to a resource adapter if the t...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Console (Show other bugs)
6.0.1,6.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: baranowb
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-17 10:19 EDT by Leticia Konno
Modified: 2014-10-25 08:36 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-16 09:21:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
myarboro: needinfo? (hbraun)


Attachments (Terms of Use)
domain.xml (73.68 KB, text/xml)
2013-05-17 10:19 EDT, Leticia Konno
no flags Details
WFLY domain.xml (79.40 KB, text/plain)
2013-06-06 07:20 EDT, baranowb
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-1492 Major Resolved Admin Console does not handle resource adapter address properly 2016-08-28 11:11 EDT

  None (edit)
Description Leticia Konno 2013-05-17 10:19:22 EDT
Created attachment 749355 [details]
domain.xml

Description of problem:

It is not possible to configure any connection definition to the resource adapter using the the management console if the resource adapter has the same name of an resource adapter configured in another profile.

Version-Release number of selected component (if applicable):
JBoss EAP 6.0.1

How reproducible:

Steps to Reproduce:
1. configure resource adapters with the same name in different profiles (domain.xml attached)
3 - restart JBoss
2. try to add a connection definition (the configuration works in the first profile defined in the domain.xml)

In the CLI is possible to see that "->1", "-2" is added to the resource adapter names (except to the ra configured in the first profile) :

[domain@localhost:9999 resource-adapter] /profile=default/subsystem=resource-adapters:read-resource
{
    "outcome" => "success",
    "result" => {"resource-adapter" => {"test" => undefined}}
}
[domain@localhost:9999 resource-adapter] /profile=ha/subsystem=resource-adapters:read-resource
{
    "outcome" => "success",
    "result" => {"resource-adapter" => {"test->1" => undefined}}
}
[domain@localhost:9999 resource-adapter] /profile=full/subsystem=resource-adapters:read-resource
{
    "outcome" => "success",
    "result" => {"resource-adapter" => {"test->2" => undefined}}
}
[domain@localhost:9999 resource-adapter] /profile=full-ha/subsystem=resource-adapters:read-resource
{
    "outcome" => "success",
    "result" => {"resource-adapter" => {"test->3" => undefined}}
}

Actual results: 

error from management console:

Unexpected HTTP response: 500

Request
{
    "address" => [],
    "operation" => "composite",
    "steps" => [{
        "enabled" => false,
        "security-application" => true,
        "jndi-name" => "java:/test",
        "background-validation" => false,
        "class-name" => "test",
        "operation" => "add",
        "address" => [
            ("profile" => "ha"),
            ("subsystem" => "resource-adapters"),
            ("resource-adapter" => "test"),
            ("connection-definitions" => "java:/test")
        ]
    }]
}

Response

Internal Server Error
{
    "outcome" => "failed",
    "result" => {"step-1" => {
        "outcome" => "failed",
        "failure-description" => "JBAS014766: Resource [
    (\"profile\" => \"ha\"),
    (\"subsystem\" => \"resource-adapters\"),
    (\"resource-adapter\" => \"test\")
] does not exist; a resource at address [
    (\"profile\" => \"ha\"),
    (\"subsystem\" => \"resource-adapters\"),
    (\"resource-adapter\" => \"test\"),
    (\"connection-definitions\" => \"java:/test\")
] cannot be created until all ancestor resources have been added",
        "rolled-back" => true
    }},
    "failure-description" => {"domain-failure-description" => {"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-1" => "JBAS014766: Resource [
    (\"profile\" => \"ha\"),
    (\"subsystem\" => \"resource-adapters\"),
    (\"resource-adapter\" => \"test\")
] does not exist; a resource at address [
    (\"profile\" => \"ha\"),
    (\"subsystem\" => \"resource-adapters\"),
    (\"resource-adapter\" => \"test\"),
    (\"connection-definitions\" => \"java:/test\")
] cannot be created until all ancestor resources have been added"}}},
    "rolled-back" => true
}
Comment 1 Leticia Konno 2013-06-03 07:11:12 EDT
This issue also affects JBoss EAP 6.1. GUI doesn't allow to disable/remove connection definitions and admin objects.
Comment 2 baranowb 2013-06-04 09:20:17 EDT
I claim thee.
Comment 4 baranowb 2013-06-06 07:20:39 EDT
Created attachment 757613 [details]
WFLY domain.xml

Attaching WFLY domain.xml, original file contains JAXR refs, which make server explode.
Comment 6 JBoss JIRA Server 2013-06-11 06:50:17 EDT
Bartosz Baranowski <bbaranow@redhat.com> made a comment on jira WFLY-1492

The "is more adapters" should be understood as "if different profiles define adapter in the same way - without ID as in first snippet"
Comment 8 JBoss JIRA Server 2013-06-24 10:38:52 EDT
Bartosz Baranowski <bbaranow@redhat.com> made a comment on jira WFLY-1492

Just to get some feedback: https://github.com/baranowb/core/tree/WFLY-1492
Comment 9 JBoss JIRA Server 2013-06-26 08:27:53 EDT
Bartosz Baranowski <bbaranow@redhat.com> made a comment on jira WFLY-1492

Since noone was against, PRs are up.
Comment 10 baranowb 2013-06-26 08:31:58 EDT
1.5.x:  https://github.com/hal/core/pull/7 
master: https://github.com/hal/core/pull/8
Comment 14 Jakub Cechacek 2014-07-16 09:21:46 EDT
This issue reported against older version, cannot be reproduced against latest 6.3.0. bits, which means it was fixed earlier. Therefore, we are closing this bug. Thank you for reporting this issue.

Note You need to log in before you can comment on or make changes to this bug.