Bug 964231 - Plugin purge may fail
Plugin purge may fail
Status: CLOSED DUPLICATE of bug 918906
Product: RHQ Project
Classification: Other
Component: Core Server (Show other bugs)
4.7
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-17 11:23 EDT by Heiko W. Rupp
Modified: 2013-08-28 12:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 12:32:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko W. Rupp 2013-05-17 11:23:07 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Heiko W. Rupp 2013-05-17 11:27:23 EDT
As BZ decided to save the entry before I was able to fill in the description ...

I was trying to get rid of most of my plugins to have faster turnaround times while working on some rest code.

After a while I got this on console:

Caused by: java.lang.RuntimeException: Failed to purge resource types
	at org.rhq.enterprise.server.inventory.InventoryManagerBean.purgeDeletedResourceType(InventoryManagerBean.java:122) [rhq-enterprise-server-ejb3.jar:4.8.0-SNAPSHOT]

Caused by: javax.ejb.EJBTransactionRolledbackException: PageList was passed an empty collection but 'totalSize' was 146, PageControl[page=1, size=200, sort[id ASC]]
	at org.rhq.enterprise.server.measurement.MeasurementDefinitionManagerLocal$$$view49.findMeasurementDefinitionsByCriteria(Unknown Source) [rhq-enterprise-server-ejb3.jar:4.8.0-SNAPSHOT]
	at org.rhq.enterprise.server.resource.metadata.MeasurementMetadataManagerBean$1.execute(MeasurementMetadataManagerBean.java:227) [rhq-enterprise-server-ejb3.jar:4.8.0-SNAPSHOT]
	at org.rhq.enterprise.server.resource.metadata.MeasurementMetadataManagerBean$1.execute(MeasurementMetadataManagerBean.java:224) [rhq-enterprise-server-ejb3.jar:4.8.0-SNAPSHOT]
	at org.rhq.enterprise.server.util.CriteriaQuery$QueryResultsIterator.next(CriteriaQuery.java:152) [rhq-enterprise-server-ejb3.jar:4.8.0-SNAPSHOT]
	at org.rhq.enterprise.server.resource.metadata.MeasurementMetadataManagerBean.deleteMetadata(MeasurementMetadataManagerBean.java:241) [rhq-enterprise-server-ejb3.jar:4.8.0-SNAPSHOT]

	at org.rhq.enterprise.server.resource.metadata.MeasurementMetadataManagerLocal$$$view150.deleteMetadata(Unknown Source) [rhq-enterprise-server-ejb3.jar:4.8.0-SNAPSHOT]
	at org.rhq.enterprise.server.resource.metadata.ResourceMetadataManagerBean.completeRemoveResourceType(ResourceMetadataManagerBean.java:366) [rhq-enterprise-server-ejb3.jar:4.8.0-SNAPSHOT]
Comment 2 Lukas Krejci 2013-08-28 12:32:28 EDT

*** This bug has been marked as a duplicate of bug 918906 ***

Note You need to log in before you can comment on or make changes to this bug.