This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 964346 - Kernel panic at boot time after upgrading from kernel 3.8.9-200 to 3.9.2-200
Kernel panic at boot time after upgrading from kernel 3.8.9-200 to 3.9.2-200
Status: CLOSED DUPLICATE of bug 964335
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-17 20:48 EDT by lu.error
Modified: 2013-05-29 11:06 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-17 21:21:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A photo of the screen capturing the kernel 3.9.2-200 oops and panic. (2.43 MB, image/png)
2013-05-17 20:48 EDT, lu.error
no flags Details
Transcript of the previous attachment. (3.09 KB, text/plain)
2013-05-17 20:52 EDT, lu.error
no flags Details

  None (edit)
Description lu.error 2013-05-17 20:48:27 EDT
Created attachment 749512 [details]
A photo of the screen capturing the kernel 3.9.2-200 oops and panic.

Description of problem:
A kernel panic occurs after a kernel oops, when trying to boot kernel 3.9.2-200 after an upgrade from kernel 3.8.9-200.

Version-Release number of selected component (if applicable):
kernel-3.9.2-200.fc18.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Install Fedora 18 and fully upgrade no further than to kernel-3.8.9-200.fc18.x86_64.
2. Perform "sudo yum upgrade".
3. Reboot and at the bootscreen choose "Fedora 18 (3.9.2-200.fc18.x86_64)".
  
Actual results:
[   3.299809] BUG: unable to handle kernel NULL pointer dereference at           (null)
[   3.299854] IP: [<ffff88003a12dfed>] 0xffff88003a12dfec
[   3.299875] PGD 0
[   3.299886] Oops: 0002 [#1] SMP
[   3.299903] Modules linked in:
[   3.299917] CPU 2
 ...
[   3.300945] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000009
[   3.300945]
_

See the attachments for a picture of the screen and a full transcription of the picture.

Expected results:
Successful boot of kernel-3.9.2-200.fc18.x86_64.

Additional info:
kernel-3.8.11-200.fc18.x86_64 does not seem to be affected by this problem; in other words I can succesfully boot with kernel-3.8.9-200.fc18.x86_64 and kernel-3.8.11-200.fc18.x86_64.

Kernel parameters for kernel-3.8.9-200.fc18.x86_64, kernel-3.8.11-200.fc18.x86_64, kernel-3.9.2-200.fc18.x86_64 are (from /etc/default/grub):

GRUB_CMDLINE_LINUX="rd.md=0 rd.lvm=0 rd.dm=0 $([ -x /usr/sbin/rhcrashkernel-param ] && /usr/sbin/rhcrashkernel-param || :) rd.luks=0 acpi_apic_instance=2 acpi_backlight=vendor discard elevator=noop log_buf_len=1M vconsole.keymap=dk-latin1 rhgb quiet"
Comment 1 lu.error 2013-05-17 20:52:03 EDT
Created attachment 749513 [details]
Transcript of the previous attachment.
Comment 2 lu.error 2013-05-17 21:21:03 EDT

*** This bug has been marked as a duplicate of bug 964335 ***

Note You need to log in before you can comment on or make changes to this bug.